summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-02-20 14:38:32 -0800
committerZac Medico <zmedico@gentoo.org>2016-02-20 14:39:12 -0800
commit128145b9bedd7140cb7d195457f3e55b9657ff4b (patch)
tree86697bcb8459b400ff4238465aead84d8c83e96f /dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
parentdev-vcs/gitolite-gentoo: bump. (diff)
downloadgentoo-128145b9bedd7140cb7d195457f3e55b9657ff4b.tar.gz
gentoo-128145b9bedd7140cb7d195457f3e55b9657ff4b.tar.bz2
gentoo-128145b9bedd7140cb7d195457f3e55b9657ff4b.zip
dev-go/go-protobuf: version bump to 0_pre20160216
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild')
-rw-r--r--dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild b/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
new file mode 100644
index 000000000000..12a260858c9a
--- /dev/null
+++ b/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/golang/protobuf
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="127091107ff5f822298f1faa7487ffcf578adcf6"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go support for Google's protocol buffers"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+ dobin bin/*
+}