summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-23 18:33:10 -0500
committerWilliam Hubbs <williamh@gentoo.org>2015-08-23 18:35:04 -0500
commit7cea8530addccd91a30b0eefed171abc44e112f2 (patch)
treeaa6704e217cd8d8e9f964a316dbfef3cb491dbe4 /dev-go/go-tools/go-tools-9999.ebuild
parentgolang-vcs.eclass: fix destination path for source files (diff)
downloadgentoo-7cea8530addccd91a30b0eefed171abc44e112f2.tar.gz
gentoo-7cea8530addccd91a30b0eefed171abc44e112f2.tar.bz2
gentoo-7cea8530addccd91a30b0eefed171abc44e112f2.zip
dev-go/go-tools: fix live ebuild for go-1.5 and newer
In Go 1.5, cover and vet have moved back to the main Go repository, so the ones in this package are deprecated.
Diffstat (limited to 'dev-go/go-tools/go-tools-9999.ebuild')
-rw-r--r--dev-go/go-tools/go-tools-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-go/go-tools/go-tools-9999.ebuild b/dev-go/go-tools/go-tools-9999.ebuild
index 3e1bc873aed2..63de13a85cc2 100644
--- a/dev-go/go-tools/go-tools-9999.ebuild
+++ b/dev-go/go-tools/go-tools-9999.ebuild
@@ -83,8 +83,13 @@ src_install() {
GOROOT="${T}/goroot" golang-build_src_install
dobin bin/* "${T}/goroot/bin/godoc"
- exeinto "$(go env GOTOOLDIR)"
- exeopts -m0755 -p # preserve timestamps for bug 551486
- doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/cover"
- doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/vet"
+ if has_version '<dev-lang/go-1.5'; then
+ exeinto "$(go env GOTOOLDIR)"
+ exeopts -m0755 -p # preserve timestamps for bug 551486
+ doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/cover"
+ doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/vet"
+ else
+ rm "${D}"/usr/bin/{cover,vet} ||
+ die "unable to remove cover and vet"
+ fi
}