summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-19 18:31:46 -0700
committerZac Medico <zmedico@gentoo.org>2018-08-19 18:46:42 -0700
commite49cc9f7451bea442690b23bb187af3b382efdf3 (patch)
tree38c191b2ade716c6372ba9a7d468d22b639d508e /dev-go/go-tour/go-tour-0_p20180810.ebuild
parentdev-tex/biber: amd64 stable wrt bug #663754 (diff)
downloadgentoo-e49cc9f7451bea442690b23bb187af3b382efdf3.tar.gz
gentoo-e49cc9f7451bea442690b23bb187af3b382efdf3.tar.bz2
gentoo-e49cc9f7451bea442690b23bb187af3b382efdf3.zip
dev-go/go-tour: version bump to 0_p20180810
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-go/go-tour/go-tour-0_p20180810.ebuild')
-rw-r--r--dev-go/go-tour/go-tour-0_p20180810.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-go/go-tour/go-tour-0_p20180810.ebuild b/dev-go/go-tour/go-tour-0_p20180810.ebuild
new file mode 100644
index 000000000000..b97a2e598afb
--- /dev/null
+++ b/dev-go/go-tour/go-tour-0_p20180810.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="golang.org/x/tour/..."
+
+EGIT_COMMIT="d642b9371986f5bb2152547a0d525a57f634c3ef"
+ARCHIVE_URI="https://github.com/golang/tour/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+inherit golang-vcs-snapshot golang-build
+
+DESCRIPTION="A Tour of Go"
+HOMEPAGE="https://tour.golang.org"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/go-tools:="
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" GOBIN="${S}/bin" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ [[ -x $(find "${T}" -name a.out) ]] || die "a.out not found"
+}
+
+src_install() {
+ GOPATH="${S}:$(get_golibdir_gopath)" GOBIN="${S}/bin" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ exeinto "$(go env GOTOOLDIR)"
+ newexe bin/gotour tour
+ insinto "$(go env GOROOT)"
+ doins -r src
+}
+
+src_test() {
+ GOPATH="${S}:$(get_golibdir_gopath)" GOBIN="${S}/bin" \
+ go test -v -work -x "${EGO_PN}" || die
+}