summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/godep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/godep')
-rw-r--r--dev-go/godep/Manifest2
-rw-r--r--dev-go/godep/godep-0_p20150520-r1.ebuild47
-rw-r--r--dev-go/godep/godep-0_p20150520.ebuild47
-rw-r--r--dev-go/godep/metadata.xml10
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-go/godep/Manifest b/dev-go/godep/Manifest
new file mode 100644
index 000000000000..655dd6dc300b
--- /dev/null
+++ b/dev-go/godep/Manifest
@@ -0,0 +1,2 @@
+DIST go-fs-2788f0dbd16903de03cb8186e5c7d97b69ad387b.tar.gz 4366 SHA256 5b8ebbacf88942136f42ccef13822c2d45f3304520be0aabc40309dcb931c707 SHA512 1d1687513caf338a82e5b15624fe7b3702fd42326c433cbf4100551a2f5aa587814201166946739a2dadfecf861661b0ed31934e13bfbe3aac6221ff2624733f WHIRLPOOL 3c38f344d232daf7109449bed55158c95f4657d9067d3623a05abadecfed274033f65375c715518c4617c30985519e735440474fb984a654739c081792c19324
+DIST godep-0_p20150520.tar.gz 20433 SHA256 3c461f14db4a65a1fa72ad3e4444986d25e75b99461b978452e65e9b751fb25d SHA512 f26bad4094ee5d35bc2cb4518094b113a84c55d196bdb59d3ffc48715151f64136cc32103bb624c28d72db97bca3aff94af71922b5daf32285421e85ee164dfd WHIRLPOOL 2a03b9c7724715a06228ac216a578974f11646f553b3e5a0c763907b673c872ac536c733f1230a15ca3603c18346a24c38ce10fe66fb779011a9a02e0f95ec3c
diff --git a/dev-go/godep/godep-0_p20150520-r1.ebuild b/dev-go/godep/godep-0_p20150520-r1.ebuild
new file mode 100644
index 000000000000..68b03ab08711
--- /dev/null
+++ b/dev-go/godep/godep-0_p20150520-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="dependency tool for go"
+GO_PN=github.com/tools/${PN}
+HOMEPAGE="https://${GO_PN}"
+EGIT_COMMIT="98f5c2e8906df47a9eaafebbcd406adde2c8d0a7"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+https://github.com/kr/fs/archive/2788f0dbd16903de03cb8186e5c7d97b69ad387b.tar.gz -> go-fs-2788f0dbd16903de03cb8186e5c7d97b69ad387b.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4:="
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+STRIP_MASK="*.a"
+
+src_unpack() {
+ default
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
+ mkdir -p src/github.com/kr || die
+ mv fs-2788f0dbd16903de03cb8186e5c7d97b69ad387b src/github.com/kr/fs || die
+}
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestSave(:_\0:' -i save_test.go || die
+ sed -e 's:TestUpdate(:_\0:' -i update_test.go || die
+}
+
+src_compile() {
+ GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
+}
+
+src_test() {
+ GOPATH=${WORKDIR} \
+ go test -x -v ${GO_PN}/... || die $?
+}
+
+src_install() {
+ dobin "${WORKDIR}"/bin/*
+}
diff --git a/dev-go/godep/godep-0_p20150520.ebuild b/dev-go/godep/godep-0_p20150520.ebuild
new file mode 100644
index 000000000000..9236e99e56b7
--- /dev/null
+++ b/dev-go/godep/godep-0_p20150520.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="dependency tool for go"
+GO_PN=github.com/tools/${PN}
+HOMEPAGE="https://${GO_PN}"
+EGIT_COMMIT="98f5c2e8906df47a9eaafebbcd406adde2c8d0a7"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+https://github.com/kr/fs/archive/2788f0dbd16903de03cb8186e5c7d97b69ad387b.tar.gz -> go-fs-2788f0dbd16903de03cb8186e5c7d97b69ad387b.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4"
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+STRIP_MASK="*.a"
+
+src_unpack() {
+ default
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
+ mkdir -p src/github.com/kr || die
+ mv fs-2788f0dbd16903de03cb8186e5c7d97b69ad387b src/github.com/kr/fs || die
+}
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestSave(:_\0:' -i save_test.go || die
+ sed -e 's:TestUpdate(:_\0:' -i update_test.go || die
+}
+
+src_compile() {
+ GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
+}
+
+src_test() {
+ GOPATH=${WORKDIR} \
+ go test -x -v ${GO_PN}/... || die $?
+}
+
+src_install() {
+ dobin "${WORKDIR}"/bin/*
+}
diff --git a/dev-go/godep/metadata.xml b/dev-go/godep/metadata.xml
new file mode 100644
index 000000000000..5171780cc31a
--- /dev/null
+++ b/dev-go/godep/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tools/godep</remote-id>
+ </upstream>
+</pkgmetadata>