summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-04-11 14:20:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-04-11 14:21:33 +0200
commit61fc8ee7729ebf345994769fd0cbc9a7b537f719 (patch)
treea3f1c1209c7de94753520901defb918e5d84ca28 /dev-go/goversion/goversion-1.2.0.ebuild
parentapp-emulation/docker: Version bump to 18.04.0 (diff)
downloadgentoo-61fc8ee7729ebf345994769fd0cbc9a7b537f719.tar.gz
gentoo-61fc8ee7729ebf345994769fd0cbc9a7b537f719.tar.bz2
gentoo-61fc8ee7729ebf345994769fd0cbc9a7b537f719.zip
dev-go/goversion: Version bump to 1.2.0
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-go/goversion/goversion-1.2.0.ebuild')
-rw-r--r--dev-go/goversion/goversion-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-go/goversion/goversion-1.2.0.ebuild b/dev-go/goversion/goversion-1.2.0.ebuild
new file mode 100644
index 000000000000..d4c4b0f2d3b3
--- /dev/null
+++ b/dev-go/goversion/goversion-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="rsc.io/goversion"
+
+inherit golang-build golang-vcs-snapshot bash-completion-r1
+ARCHIVE_URI="https://github.com/rsc/goversion/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Print version used to build Go executables"
+HOMEPAGE="https://github.com/rsc/goversion https://rsc.io/goversion"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -o ${PN} . || die
+ popd || die
+}
+
+src_install() {
+ dobin src/${EGO_PN}/${PN}
+ dodoc src/${EGO_PN}/README.md
+}