summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/aeson-pretty
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/aeson-pretty')
-rw-r--r--dev-haskell/aeson-pretty/Manifest3
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild36
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.7.2.ebuild36
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild36
-rw-r--r--dev-haskell/aeson-pretty/metadata.xml27
5 files changed, 138 insertions, 0 deletions
diff --git a/dev-haskell/aeson-pretty/Manifest b/dev-haskell/aeson-pretty/Manifest
new file mode 100644
index 000000000000..bb2216a45ac9
--- /dev/null
+++ b/dev-haskell/aeson-pretty/Manifest
@@ -0,0 +1,3 @@
+DIST aeson-pretty-0.7.1.tar.gz 4811 SHA256 c68ff70d0149a6f1f38345393cc0493d5ce6bfb22fc8e89bf3ceaad5ea0cb53e SHA512 53522c5235b8252c0a293ebe6a988cfb7f61cc575df664a27851652a47b948acd322898e70e128c91d1aaf6b5bd27c8a1717edcc3ea423f34e7943791a301326 WHIRLPOOL c4a311a05ca7ef0613fc458140dbaf2a2dac00c27c1afcbd868b88fec68c7b9a3de309051a8f143ed8a499b286ac95680c41809eabccf6aeab9b08e81f2e993d
+DIST aeson-pretty-0.7.2.tar.gz 4838 SHA256 6408b8b2bcd12cf591e4b93b4d9f5143449b33a59fbd3653f328e2515040570d SHA512 beabdb13c1a7c5a8fa7acdfe0e0f7b6b00d901d6aada360c17e43704cddd92d6464901885dd529710cc090c9649aa63b7241a5155178f0ff27145ed1ef4f347b WHIRLPOOL 8bab7c7527312a3c61f0232482f7b2418ae13a7d16d6b586278795a38ea8703830da68d2582e0a0dfee404a3c457c36934de8adcde882111bdc96f3ce274e574
+DIST aeson-pretty-0.7.tar.gz 4805 SHA256 e79d5b16709f30088859c6f8a35399d3bdde0ed63a41818a041be44adcd0787e SHA512 97590dcdb044d1ecb6b8acf5dedc0aedcf98743ae2b54346f199ab5ce5a954d79913d9fdb3ce94ca20797219c647dccc150e5ca9e531fa173bcd96464b40950a WHIRLPOOL 16e13cf79925708141c4a8aa0aef0a3f3743953d40be00b1a0c62f6222098116990b5f63391cefcfacb35ebaf342b8d36370c46d22f05b166869e65f7617231e
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild
new file mode 100644
index 000000000000..ba5cbd14ffea
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="http://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.7.2.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.7.2.ebuild
new file mode 100644
index 000000000000..9ff3bb8725be
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.7.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="http://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild
new file mode 100644
index 000000000000..97397f0cfe06
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="http://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}
diff --git a/dev-haskell/aeson-pretty/metadata.xml b/dev-haskell/aeson-pretty/metadata.xml
new file mode 100644
index 000000000000..8d52094eea89
--- /dev/null
+++ b/dev-haskell/aeson-pretty/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <use>
+ <flag name="lib-only">don't build 'aeson-pretty' executable.</flag>
+ </use>
+ <longdescription>
+ A JSON pretty-printing library compatible with aeson as well as
+ a command-line tool to improve readabilty of streams of JSON data.
+
+ The /library/ provides the function "encodePretty". It is a drop-in
+ replacement for aeson's "encode" function, producing JSON-ByteStrings for
+ human readers.
+
+ The /command-line tool/ reads JSON from stdin and writes prettified JSON
+ to stdout. It also offers a complementary "compact"-mode, essentially the
+ opposite of pretty-printing. If you specify @-flib-only@ like this
+
+ &gt; cabal install -flib-only aeson-pretty
+
+ the command-line tool will NOT be installed.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">informatikr/aeson-pretty</remote-id>
+ </upstream>
+</pkgmetadata>