summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/alex/alex-3.1.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/alex/alex-3.1.3.ebuild')
-rw-r--r--dev-haskell/alex/alex-3.1.3.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-haskell/alex/alex-3.1.3.ebuild b/dev-haskell/alex/alex-3.1.3.ebuild
new file mode 100644
index 000000000000..c5d7d7dabe4e
--- /dev/null
+++ b/dev-haskell/alex/alex-3.1.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit autotools haskell-cabal
+
+DESCRIPTION="Alex is a tool for generating lexical analysers in Haskell"
+HOMEPAGE="http://www.haskell.org/alex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ia64 ppc ppc64 sparc x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-haskell/quickcheck-2
+ >=dev-lang/ghc-6.10.4
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+
+src_prepare() {
+ # drop depend on itself and happy, otherwise cabal tries to regenerate it
+ rm src/{Scan.x,Parser.y} || die
+
+ for f in Scan Parser; do
+ mv "${S}/dist/build/alex/alex-tmp/$f.hs" "${S}"/src/ || die
+ done
+
+ if use doc; then
+ cd "${S}/doc/"
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # make sure we don't accidentally use those
+ # installed in system
+ haskell-cabal_src_configure \
+ --with-alex=false \
+ --with-happy=false
+
+ if use doc; then
+ cd "${S}/doc/"
+ econf
+ fi
+}
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C "${S}/doc/" -j1
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ if use doc; then
+ doman "${S}/doc/alex.1"
+ dohtml -r "${S}/doc/alex/"
+ fi
+ dodoc README
+}