summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-26 22:04:53 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-26 22:04:53 +0100
commit17fe17984ad23735adff4e2723c562751d3cd7c6 (patch)
tree5d399cb143d9d335dcb4c3b7beb8f27ed359cc46 /dev-haskell/alsa-core
parentdev-haskell/pandoc-types: drop longdescription (diff)
downloadgentoo-17fe17984ad23735adff4e2723c562751d3cd7c6.tar.gz
gentoo-17fe17984ad23735adff4e2723c562751d3cd7c6.tar.bz2
gentoo-17fe17984ad23735adff4e2723c562751d3cd7c6.zip
dev-haskell/alsa-core: switch to EAPI=7
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/alsa-core')
-rw-r--r--dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild b/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild
index 98195b831952..c94cd28992d4 100644
--- a/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild
+++ b/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.1.9999
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: +pkgconfig
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -17,9 +18,16 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?]
- <dev-haskell/extensible-exceptions-0.2:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- media-libs/alsa-lib"
+RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ media-libs/alsa-lib
+"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8"
+ >=dev-haskell/cabal-1.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=pkgconfig
+}