summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 14:56:59 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 14:56:59 +0100
commit5de3d66f6fe264195d6b8cd0098343a3b8751114 (patch)
treee69a35f1d86d79c0996400a7862ababe9f458097 /dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild
parentpackage.mask: mask dev-haskell/base64-conduit for removal (diff)
downloadgentoo-5de3d66f6fe264195d6b8cd0098343a3b8751114.tar.gz
gentoo-5de3d66f6fe264195d6b8cd0098343a3b8751114.tar.bz2
gentoo-5de3d66f6fe264195d6b8cd0098343a3b8751114.zip
dev-haskell/arithmoi: bump up to 0.4.2.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild')
-rw-r--r--dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild b/dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild
new file mode 100644
index 000000000000..f5251dfffaae
--- /dev/null
+++ b/dev-haskell/arithmoi/arithmoi-0.4.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -check-bounds
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
+HOMEPAGE="https://github.com/cartazio/arithmoi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.8 <dev-haskell/quickcheck-2.9
+ >=dev-haskell/smallcheck-1.1 <dev-haskell/smallcheck-1.2
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9
+ >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-check-bounds
+}