summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-05 22:54:20 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:23:01 +0000
commit2eb33a91b6328c1861518719454099cea2e92d00 (patch)
treeb8625808853d57095a99cad3df6e4ea222936c53 /dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild
parentdev-haskell/alex: bump up to 3.2.1 (diff)
downloadgentoo-2eb33a91b6328c1861518719454099cea2e92d00.tar.gz
gentoo-2eb33a91b6328c1861518719454099cea2e92d00.tar.bz2
gentoo-2eb33a91b6328c1861518719454099cea2e92d00.zip
dev-haskell/arithmoi: bump up to 0.4.3.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild')
-rw-r--r--dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild b/dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild
new file mode 100644
index 000000000000..c4f37a03ef24
--- /dev/null
+++ b/dev-haskell/arithmoi/arithmoi-0.4.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -check-bounds
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
+HOMEPAGE="https://github.com/cartazio/arithmoi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/semigroups-0.8:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-2.7.6 <dev-haskell/quickcheck-2.10
+ >=dev-haskell/smallcheck-1.1 <dev-haskell/smallcheck-1.2
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9
+ >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9
+ >=dev-haskell/transformers-compat-0.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-check-bounds
+}