summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/asn1-parse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/asn1-parse')
-rw-r--r--dev-haskell/asn1-parse/Manifest3
-rw-r--r--dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild29
-rw-r--r--dev-haskell/asn1-parse/asn1-parse-0.9.0.ebuild29
-rw-r--r--dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild28
-rw-r--r--dev-haskell/asn1-parse/metadata.xml11
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-haskell/asn1-parse/Manifest b/dev-haskell/asn1-parse/Manifest
new file mode 100644
index 000000000000..0aad4b852860
--- /dev/null
+++ b/dev-haskell/asn1-parse/Manifest
@@ -0,0 +1,3 @@
+DIST asn1-parse-0.8.1.tar.gz 2724 SHA256 09567b3f06d428a194fe8132acf002f8dbfb8694a113dce14edd79a54a5d3508 SHA512 d175903a4e2eacaf56b3c641c3a78adebfdbe263678a59c0ba44d5c1185408800f1aabad3d0ce622fe1029e204699477b36565df5bd1049ebba0df10f72eb128 WHIRLPOOL bed35b1bb93017bfc3805e48b88b802cd9d829697f9521a84341748b86bf6ff497bbfa8dc0a9ca4974ecf86c825c2ea029155ea3294faa53dcf6ce0900961165
+DIST asn1-parse-0.9.0.tar.gz 2801 SHA256 e3c94b982c34e944c549b7854d738d50158eee0267598ac5f1bbfb66391f0954 SHA512 8c358864b863721d71b0ba45991dddfa0e529bf34fe5483e4904bb56b9e1ff0bd03335f71677eecfb7da96a3d6efe0bfd9ea2684b3c6ba4cd7ab28ab26d2f66a WHIRLPOOL e8e8c0402a6731788361ebf623ca265b53e8db6d00c3eea4849f5e42616e454cb8742f99d9382ffffc0546b73add61901184cdcb2f6a34faa75ce26cdcea80b1
+DIST asn1-parse-0.9.1.tar.gz 2785 SHA256 e18087baa87225a5ea41c9758f7499b362ba6293931cb9c5bc3548c90f3133de SHA512 69799adf27188a8b1468cfc35c5a17ffe668aa30f585e8d8ff0b9153936a8825e9d548fca38d8e4ea5823ae511f179c5b56c5fe804260048bd3c5e373a077d17 WHIRLPOOL 6f81e452b09d0f9a3e1a521c3332651130aab042b256aa80a9c35f398ef4f8093946bcc473effb7a53bca36ef26120f979606cebe97e6f5399c2cb6e080ac853
diff --git a/dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild b/dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild
new file mode 100644
index 000000000000..4b6d15bf656c
--- /dev/null
+++ b/dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple monadic parser for ASN1 stream types"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.8:=[profile?]
+ >=dev-haskell/asn1-types-0.2:=[profile?] <dev-haskell/asn1-types-0.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/asn1-parse/asn1-parse-0.9.0.ebuild b/dev-haskell/asn1-parse/asn1-parse-0.9.0.ebuild
new file mode 100644
index 000000000000..d3ddec9d8ce5
--- /dev/null
+++ b/dev-haskell/asn1-parse/asn1-parse-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple monadic parser for ASN1 stream types"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild b/dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild
new file mode 100644
index 000000000000..036d70813fc8
--- /dev/null
+++ b/dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple monadic parser for ASN1 stream types"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/asn1-parse/metadata.xml b/dev-haskell/asn1-parse/metadata.xml
new file mode 100644
index 000000000000..4a79e9750ac7
--- /dev/null
+++ b/dev-haskell/asn1-parse/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Simple monadic parser for ASN1 stream types, when ASN1 pattern matching is not convenient.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-asn1</remote-id>
+ </upstream>
+</pkgmetadata>