summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/base-unicode-symbols
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/base-unicode-symbols')
-rw-r--r--dev-haskell/base-unicode-symbols/Manifest2
-rw-r--r--dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.3.ebuild30
-rw-r--r--dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.4.ebuild23
-rw-r--r--dev-haskell/base-unicode-symbols/files/base-unicode-symbols-0.2.2.3-ghc-7.5.patch87
-rw-r--r--dev-haskell/base-unicode-symbols/metadata.xml27
5 files changed, 169 insertions, 0 deletions
diff --git a/dev-haskell/base-unicode-symbols/Manifest b/dev-haskell/base-unicode-symbols/Manifest
new file mode 100644
index 000000000000..84cc397d8210
--- /dev/null
+++ b/dev-haskell/base-unicode-symbols/Manifest
@@ -0,0 +1,2 @@
+DIST base-unicode-symbols-0.2.2.3.tar.gz 5549 SHA256 1201fcc936cf4328153d9ac7e20f797d904ac14ed6493689ddb1cfe61bb30320 SHA512 a8c84e9103dc437a795297d9cbc6adbf99492f5417bf17133f1e5e8700f149e72a1cf7a58540ac5a0878c3baa9daa77aeec3b557645efca7f4312262f0d10460 WHIRLPOOL 8a2981ffa0ff662fe6b41c08ae80145bdb255e737a53e6e5bf67eec396dcbc5b5af3562942a7ccf720cf9b7460fde64f659aa03df012669774a2a5ae67503f92
+DIST base-unicode-symbols-0.2.2.4.tar.gz 5562 SHA256 a2f841430fec32edba778b74bde83bf0170ada7c5e2e59d7187c8f06d92dcca9 SHA512 8dcdafa1075ccea8f188b880b90430b7e86270f68fcca47bbee7fa7e695bc90765566e09a0f032103d8cf2a265069e80288f56714190c9e68470141e469a994d WHIRLPOOL cca678b2bf532b5544ca1f155aec8a1cb2e00dd0972c26d1f8591695b78a607282751d72935ed6ed9d39e9adad9c70d2379ede789a01713d47d30448babd7cb8
diff --git a/dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.3.ebuild b/dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.3.ebuild
new file mode 100644
index 000000000000..79c92f64eaf8
--- /dev/null
+++ b/dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Unicode alternatives for common functions and operators"
+HOMEPAGE="http://haskell.org/haskellwiki/Unicode-symbols"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ if has_version ">=dev-lang/ghc-7.5.20120511"; then
+ # change the unicode -> to ascii ->
+ epatch "${FILESDIR}/${PN}-0.2.2.3-ghc-7.5.patch"
+ fi
+ cabal_chdeps \
+ 'base >= 3.0.3.1 && < 4.6' 'base >= 3.0.3.1 && < 5'
+}
diff --git a/dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.4.ebuild b/dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.4.ebuild
new file mode 100644
index 000000000000..01f2a4308959
--- /dev/null
+++ b/dev-haskell/base-unicode-symbols/base-unicode-symbols-0.2.2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Unicode alternatives for common functions and operators"
+HOMEPAGE="http://haskell.org/haskellwiki/Unicode-symbols"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/base-unicode-symbols/files/base-unicode-symbols-0.2.2.3-ghc-7.5.patch b/dev-haskell/base-unicode-symbols/files/base-unicode-symbols-0.2.2.3-ghc-7.5.patch
new file mode 100644
index 000000000000..99867402234a
--- /dev/null
+++ b/dev-haskell/base-unicode-symbols/files/base-unicode-symbols-0.2.2.3-ghc-7.5.patch
@@ -0,0 +1,87 @@
+--- base-unicode-symbols-0.2.2.3-orig/Control/Arrow/Unicode.hs 2011-12-17 22:21:02.000000000 +1100
++++ base-unicode-symbols-0.2.2.3/Control/Arrow/Unicode.hs 2012-05-14 00:13:42.547126948 +1000
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE CPP, NoImplicitPrelude, UnicodeSyntax, TypeOperators #-}
++{-# LANGUAGE CPP, NoImplicitPrelude, UnicodeSyntax, TypeOperators, FlexibleContexts #-}
+
+ {-|
+ Module : Control.Arrow.Unicode
+@@ -58,7 +58,7 @@
+
+ U+2042, ASTERISM
+ -}
+-(⁂) ∷ Arrow (⇝) ⇒ (α ⇝ β) → (α' ⇝ β') → (α, α') ⇝ (β, β')
++(⁂) ∷ Arrow (->) ⇒ (α -> β) → (α' -> β') → (α, α') -> (β, β')
+ (⁂) = (***)
+ {-# INLINE (⁂) #-}
+ #endif
+@@ -68,7 +68,7 @@
+
+ U+29FB, TRIPLE PLUS
+ -}
+-(⧻) ∷ ArrowChoice (⇝) ⇒ (α ⇝ β) → (α' ⇝ β') → (Either α α' ⇝ Either β β')
++(⧻) ∷ ArrowChoice (->) ⇒ (α -> β) → (α' -> β') → (Either α α' -> Either β β')
+ (⧻) = (+++)
+ {-# INLINE (⧻) #-}
+
+@@ -77,7 +77,7 @@
+
+ U+2AF4, TRIPLE VERTICAL BAR BINARY RELATION
+ -}
+-(⫴) ∷ ArrowChoice (⇝) ⇒ (α ⇝ δ) → (β ⇝ δ) → (Either α β ⇝ δ)
++(⫴) ∷ ArrowChoice (->) ⇒ (α -> δ) → (β -> δ) → (Either α β -> δ)
+ (⫴) = (|||)
+ {-# INLINE (⫴) #-}
+
+@@ -87,7 +87,7 @@
+
+ U+22D9, VERY MUCH GREATER-THAN
+ -}
+-(⋙) ∷ Arrow (⇝) ⇒ (α ⇝ β) → (β ⇝ γ) → (α ⇝ γ)
++(⋙) ∷ Arrow (->) ⇒ (α -> β) → (β -> γ) → (α -> γ)
+ (⋙) = (>>>)
+ {-# INLINE (⋙) #-}
+
+@@ -96,7 +96,7 @@
+
+ U+22D8, VERY MUCH LESS-THAN
+ -}
+-(⋘) ∷ Arrow (⇝) ⇒ (β ⇝ γ) → (α ⇝ β) → (α ⇝ γ)
++(⋘) ∷ Arrow (->) ⇒ (β -> γ) → (α -> β) → (α -> γ)
+ (⋘) = (<<<)
+ {-# INLINE (⋘) #-}
+ #endif
+--- base-unicode-symbols-0.2.2.3-orig/Control/Category/Unicode.hs 2011-12-17 22:21:02.000000000 +1100
++++ base-unicode-symbols-0.2.2.3/Control/Category/Unicode.hs 2012-05-14 00:13:19.067598372 +1000
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE NoImplicitPrelude, UnicodeSyntax, TypeOperators #-}
++{-# LANGUAGE NoImplicitPrelude, UnicodeSyntax, TypeOperators, FlexibleContexts #-}
+
+ {-|
+ Module : Control.Category.Unicode
+@@ -35,7 +35,7 @@
+
+ U+2218, RING OPERATOR
+ -}
+-(∘) ∷ Category (⇝) ⇒ (β ⇝ γ) → (α ⇝ β) → (α ⇝ γ)
++(∘) ∷ Category (->) ⇒ (β -> γ) → (α -> β) → (α -> γ)
+ (∘) = (.)
+ {-# INLINE (∘) #-}
+
+@@ -44,7 +44,7 @@
+
+ U+22D9, VERY MUCH GREATER-THAN
+ -}
+-(⋙) ∷ Category (⇝) ⇒ (α ⇝ β) → (β ⇝ γ) → (α ⇝ γ)
++(⋙) ∷ Category (->) ⇒ (α -> β) → (β -> γ) → (α -> γ)
+ (⋙) = (>>>)
+ {-# INLINE (⋙) #-}
+
+@@ -53,6 +53,6 @@
+
+ U+22D8, VERY MUCH LESS-THAN
+ -}
+-(⋘) ∷ Category (⇝) ⇒ (β ⇝ γ) → (α ⇝ β) → (α ⇝ γ)
++(⋘) ∷ Category (->) ⇒ (β -> γ) → (α -> β) → (α -> γ)
+ (⋘) = (<<<)
+ {-# INLINE (⋘) #-}
diff --git a/dev-haskell/base-unicode-symbols/metadata.xml b/dev-haskell/base-unicode-symbols/metadata.xml
new file mode 100644
index 000000000000..018d10a91ea6
--- /dev/null
+++ b/dev-haskell/base-unicode-symbols/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package defines new symbols for a number of functions,
+ operators and types in the base package.
+
+ All symbols are documented with their actual definition and
+ information regarding their Unicode code point. They should be
+ completely interchangeable with their definitions.
+
+ For further Unicode goodness you can enable the @UnicodeSyntax@
+ language extension \[1\]. This extension enables Unicode characters
+ to be used to stand for certain ASCII character sequences,
+ i.e. &amp;#x2192; instead of @-&gt;@, &amp;#x2200; instead of @forall@ and many
+ others.
+
+ Original idea by P&amp;#xE9;ter Divi&amp;#xE1;nszky.
+
+ \[1\] &lt;http://www.haskell.org/ghc/docs/latest/html/users_guide/syntax-extns.html#unicode-syntax&gt;
+ </longdescription>
+</pkgmetadata>