summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-21 17:41:01 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:14:53 +0000
commit912d40e7db00c5fdc4539e0bf5bd0ebb8c82189c (patch)
treea81a9e2c6f953e498cb1577e4d21a293c1b16e76 /dev-haskell/binary
parentdev-haskell/bifunctors: add 5.5.11 (diff)
downloadgentoo-912d40e7db00c5fdc4539e0bf5bd0ebb8c82189c.tar.gz
gentoo-912d40e7db00c5fdc4539e0bf5bd0ebb8c82189c.tar.bz2
gentoo-912d40e7db00c5fdc4539e0bf5bd0ebb8c82189c.zip
dev-haskell/binary: add 0.8.8.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/binary')
-rw-r--r--dev-haskell/binary/Manifest1
-rw-r--r--dev-haskell/binary/binary-0.8.8.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/binary/Manifest b/dev-haskell/binary/Manifest
index acf2a3a47684..46480c712b55 100644
--- a/dev-haskell/binary/Manifest
+++ b/dev-haskell/binary/Manifest
@@ -1 +1,2 @@
DIST binary-0.8.7.0.tar.gz 57443 BLAKE2B 27d892ff28410e37fa9c8f3b852bf6c420fee8c7241815737c7c488e0e1754685ad4efe6a93eed055638870c0b64dc311e1c6e6bc6bf498420f1640557d4ef27 SHA512 2648ea70b6615c01a0e336b3fc187ecb0ad298c620df056da250fa237a2614d23f2ad11a0b11216d799aabb107f89b89d8e63daa30868bf8829ba358b9586aff
+DIST binary-0.8.8.0.tar.gz 57327 BLAKE2B c105f4bf92ec52df51d3c7bda1aae99b3d40727aa4d3c1397431b2b727a934e62ee1f9ab7ed45b3502b17bd7a9a61f95a2a66690e40ae25b177fc8c79c462ae5 SHA512 9e4b116a2661d7970dbcf5ec3432ce88514380cab145358c3368a2dca35a16ab9d1f0d09ce2eb853a456764215744195d593629fb08e29b627345e3ae913592f
diff --git a/dev-haskell/binary/binary-0.8.8.0.ebuild b/dev-haskell/binary/binary-0.8.8.0.ebuild
new file mode 100644
index 000000000000..dae0bfaf3187
--- /dev/null
+++ b/dev-haskell/binary/binary-0.8.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circular depend: test-suite"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
+HOMEPAGE="https://github.com/kolmodin/binary"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.10
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT=test # circular depend: test-framework->base-orphans->cabal->semigroups->nats->binary
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.10.5-r1 PM:8.10.6 PM:8.10.7 PM:9.0.1-r1 PM:9.0.2 PM:9999"