summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:06:26 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:18 +0100
commitcfdc684d0f0fcef1fc17c9a02a88d23610762c45 (patch)
treec7eefdda3949b262b9a0d93ada2667fde09ca59b /dev-haskell/bloomfilter/bloomfilter-2.0.1.0-r1.ebuild
parentdev-haskell/blaze-markup: Hackage revision bump (diff)
downloadgentoo-cfdc684d0f0fcef1fc17c9a02a88d23610762c45.tar.gz
gentoo-cfdc684d0f0fcef1fc17c9a02a88d23610762c45.tar.bz2
gentoo-cfdc684d0f0fcef1fc17c9a02a88d23610762c45.zip
dev-haskell/bloomfilter: add 2.0.1.0-r1
Hackage revision bump, add patch Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/bloomfilter/bloomfilter-2.0.1.0-r1.ebuild')
-rw-r--r--dev-haskell/bloomfilter/bloomfilter-2.0.1.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/bloomfilter/bloomfilter-2.0.1.0-r1.ebuild b/dev-haskell/bloomfilter/bloomfilter-2.0.1.0-r1.ebuild
new file mode 100644
index 000000000000..89eb41c70f59
--- /dev/null
+++ b/dev-haskell/bloomfilter/bloomfilter-2.0.1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.1.0.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure and impure Bloom Filter implementations"
+HOMEPAGE="https://github.com/bos/bloomfilter"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.1.0-ghc-9_2-fix.patch"
+)
+
+CABAL_CHDEPS=(
+ 'base >= 4.4 && < 4.16' 'base >= 4.4'
+ 'base >= 4.4 && < 4.16' 'base >= 4.4'
+)
+
+RDEPEND=">=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/random
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2
+ )
+"