summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:18 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:50 +0100
commit9d86e72d33e23628015864505baac7d79565ed7d (patch)
tree5b57656e16e05f8945cc4f420423b45ef47403ff /dev-haskell/cabal/cabal-3.6.3.0.ebuild
parentdev-haskell/cabal: Hackage revision bump (diff)
downloadgentoo-9d86e72d33e23628015864505baac7d79565ed7d.tar.gz
gentoo-9d86e72d33e23628015864505baac7d79565ed7d.tar.bz2
gentoo-9d86e72d33e23628015864505baac7d79565ed7d.zip
dev-haskell/cabal: add 3.6.3.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/cabal/cabal-3.6.3.0.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-3.6.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-3.6.3.0.ebuild b/dev-haskell/cabal/cabal-3.6.3.0.ebuild
new file mode 100644
index 000000000000..444173981907
--- /dev/null
+++ b/dev-haskell/cabal/cabal-3.6.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.2.2.9999
+#hackport: flags: -parsec-struct-diff
+
+CABAL_PN="Cabal"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="https://www.haskell.org/cabal/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-lang/ghc-9.2.4:=
+"
+DEPEND="${RDEPEND}
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-parsec-struct-diff
+}
+
+CABAL_CORE_LIB_GHC_PV="9.2.4 9.2.5 9.2.6 9.2.7 9.2.8"