summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/cmark
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/cmark')
-rw-r--r--dev-haskell/cmark/cmark-0.3.4.ebuild4
-rw-r--r--dev-haskell/cmark/cmark-0.4.0.1.ebuild4
-rw-r--r--dev-haskell/cmark/cmark-0.5.5.ebuild4
-rw-r--r--dev-haskell/cmark/cmark-0.5.6.ebuild4
-rw-r--r--dev-haskell/cmark/cmark-0.6.ebuild2
5 files changed, 9 insertions, 9 deletions
diff --git a/dev-haskell/cmark/cmark-0.3.4.ebuild b/dev-haskell/cmark/cmark-0.3.4.ebuild
index f2e8dda78a9f..5ee4921b3acc 100644
--- a/dev-haskell/cmark/cmark-0.3.4.ebuild
+++ b/dev-haskell/cmark/cmark-0.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
HOMEPAGE="https://github.com/jgm/commonmark-hs"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/cmark/cmark-0.4.0.1.ebuild b/dev-haskell/cmark/cmark-0.4.0.1.ebuild
index 724892a0dfca..277d5e275ec3 100644
--- a/dev-haskell/cmark/cmark-0.4.0.1.ebuild
+++ b/dev-haskell/cmark/cmark-0.4.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
HOMEPAGE="https://github.com/jgm/commonmark-hs"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/cmark/cmark-0.5.5.ebuild b/dev-haskell/cmark/cmark-0.5.5.ebuild
index ee5f940e742d..331e379a58ad 100644
--- a/dev-haskell/cmark/cmark-0.5.5.ebuild
+++ b/dev-haskell/cmark/cmark-0.5.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
HOMEPAGE="https://github.com/jgm/cmark-hs"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/cmark/cmark-0.5.6.ebuild b/dev-haskell/cmark/cmark-0.5.6.ebuild
index a980c29c31d9..02193b3fb50f 100644
--- a/dev-haskell/cmark/cmark-0.5.6.ebuild
+++ b/dev-haskell/cmark/cmark-0.5.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
HOMEPAGE="https://github.com/jgm/cmark-hs"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/cmark/cmark-0.6.ebuild b/dev-haskell/cmark/cmark-0.6.ebuild
index e5097d0ec03b..5d36f5081c5e 100644
--- a/dev-haskell/cmark/cmark-0.6.ebuild
+++ b/dev-haskell/cmark/cmark-0.6.ebuild
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
HOMEPAGE="https://github.com/jgm/cmark-hs"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"