summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-15 23:11:32 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:50 +0000
commit15ea174195b101dfed92ad010864b554bcef2512 (patch)
tree9b14989a4e44899eb5d289ad5389de427351dbb7 /dev-haskell/comonad/comonad-5.ebuild
parentdev-haskell/adjunctions: bump up to 4.3 (diff)
downloadgentoo-15ea174195b101dfed92ad010864b554bcef2512.tar.gz
gentoo-15ea174195b101dfed92ad010864b554bcef2512.tar.bz2
gentoo-15ea174195b101dfed92ad010864b554bcef2512.zip
dev-haskell/comonad: bump up to 5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/comonad/comonad-5.ebuild')
-rw-r--r--dev-haskell/comonad/comonad-5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/comonad/comonad-5.ebuild b/dev-haskell/comonad/comonad-5.ebuild
new file mode 100644
index 000000000000..aa4fdf6b1bf1
--- /dev/null
+++ b/dev-haskell/comonad/comonad-5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Comonads"
+HOMEPAGE="https://github.com/ekmett/comonad/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+containers +contravariant +distributive +test-doctests"
+
+RDEPEND=">=dev-haskell/semigroups-0.8.3.1:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ contravariant? ( >=dev-haskell/contravariant-0.2.0.1:=[profile?] <dev-haskell/contravariant-2:=[profile?] )
+ distributive? ( >=dev-haskell/distributive-0.2.2:=[profile?] <dev-haskell/distributive-1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( test-doctests? ( >=dev-haskell/doctest-0.9.10 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag containers containers) \
+ $(cabal_flag contravariant contravariant) \
+ $(cabal_flag distributive distributive) \
+ $(cabal_flag test-doctests test-doctests)
+}