summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/conduit-extra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/conduit-extra')
-rw-r--r--dev-haskell/conduit-extra/Manifest2
-rw-r--r--dev-haskell/conduit-extra/conduit-extra-1.1.7.1-r1.ebuild42
-rw-r--r--dev-haskell/conduit-extra/conduit-extra-1.1.9.1.ebuild41
-rw-r--r--dev-haskell/conduit-extra/metadata.xml11
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-haskell/conduit-extra/Manifest b/dev-haskell/conduit-extra/Manifest
new file mode 100644
index 000000000000..fca530f28ef1
--- /dev/null
+++ b/dev-haskell/conduit-extra/Manifest
@@ -0,0 +1,2 @@
+DIST conduit-extra-1.1.7.1.tar.gz 28862 SHA256 a34bbabb1f167042540a8d56010239e5ffb3f6136d471584168912e23193f8e2 SHA512 bf1e860132b09d05c6279ee5ee3528159eb6dc01f1d141a453708ba00c541728e9cc3d7c7d9200a9a52d9e3ba2c18940c98665e7a54c5747df991afa3b04951d WHIRLPOOL 832ee2d42f77ac08a9210a2fd3879b1ddba077895718f320a02b69ea60250dcc3c30c2f6765b500cab78cbbca1da711b9596588e4a7e229d5ac698ef2f0dff08
+DIST conduit-extra-1.1.9.1.tar.gz 29571 SHA256 3f1be15bef32652caa9a98e175c95614c0f6d04ca29c35d30ddbc940a90fa0a3 SHA512 3e35c303fb9696f99af99db6ada5e59dcde09e0ce3d3559aed2b3354dab1a96d523b7976643239892316a709289e4943aea37152a2935c6c256b24e5b73dc716 WHIRLPOOL c1e4e6325a32ab0b8fa9fe788ac6b0437bf352793bc71403d9f9e3946b807acdd01dfcd6426238579c4e6f48aaa2ebdbf3db2a6c9f93c4f107f75367ae38a933
diff --git a/dev-haskell/conduit-extra/conduit-extra-1.1.7.1-r1.ebuild b/dev-haskell/conduit-extra/conduit-extra-1.1.7.1-r1.ebuild
new file mode 100644
index 000000000000..ad2a6dfb43ef
--- /dev/null
+++ b/dev-haskell/conduit-extra/conduit-extra-1.1.7.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Batteries included conduit: adapters for common libraries"
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ dev-haskell/bytestring-builder:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/primitive-0.5:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.10:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/async
+ dev-haskell/bytestring-builder
+ dev-haskell/exceptions
+ >=dev-haskell/hspec-1.3 )
+"
diff --git a/dev-haskell/conduit-extra/conduit-extra-1.1.9.1.ebuild b/dev-haskell/conduit-extra/conduit-extra-1.1.9.1.ebuild
new file mode 100644
index 000000000000..fa4f6640e834
--- /dev/null
+++ b/dev-haskell/conduit-extra/conduit-extra-1.1.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Batteries included conduit: adapters for common libraries"
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/primitive-0.5:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.11:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/async
+ dev-haskell/bytestring-builder
+ dev-haskell/exceptions
+ >=dev-haskell/hspec-1.3 )
+"
diff --git a/dev-haskell/conduit-extra/metadata.xml b/dev-haskell/conduit-extra/metadata.xml
new file mode 100644
index 000000000000..ad0e865ef3c8
--- /dev/null
+++ b/dev-haskell/conduit-extra/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package will soon contain much more functionality. This is a placeholder until the next release is ready.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/conduit</remote-id>
+ </upstream>
+</pkgmetadata>