summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-14 12:30:17 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-15 11:04:57 -0400
commit433b6ea76a0905ce211403aaed013d571366c06c (patch)
tree5446fe652d7d9be7d0f6c3ac7b78d2aebe00a2c9 /dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild
parentnet-misc/aria2: Bump to 1.25.0 (bugfix release) (diff)
downloadgentoo-433b6ea76a0905ce211403aaed013d571366c06c.tar.gz
gentoo-433b6ea76a0905ce211403aaed013d571366c06c.tar.bz2
gentoo-433b6ea76a0905ce211403aaed013d571366c06c.zip
dev-haskell/configurator: new package to read config files in Haskell.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild')
-rw-r--r--dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild b/dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild
new file mode 100644
index 000000000000..c58f248aaece
--- /dev/null
+++ b/dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.2.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Configuration management"
+HOMEPAGE="https://github.com/bos/configurator"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0.2:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ >=dev-haskell/text-0.11.1.0:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}