summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/crypto-api
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/crypto-api')
-rw-r--r--dev-haskell/crypto-api/Manifest3
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild32
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.13.2.ebuild34
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.13.ebuild34
-rw-r--r--dev-haskell/crypto-api/metadata.xml22
5 files changed, 125 insertions, 0 deletions
diff --git a/dev-haskell/crypto-api/Manifest b/dev-haskell/crypto-api/Manifest
new file mode 100644
index 000000000000..76a1ab49467d
--- /dev/null
+++ b/dev-haskell/crypto-api/Manifest
@@ -0,0 +1,3 @@
+DIST crypto-api-0.12.2.2.tar.gz 45271 SHA256 33ec873929013e9b0fefeddfdecffd445f1afdf426a3e3c41c5aaefce346bb62 SHA512 340aefd9f8b24d99866fce26bd3eaba8484be6e15648a2ff1a0a051f8974514a50f809f8d2539c7fe747dbe1b6946a1ecfa8a2966548391e71b498d19e79cc86 WHIRLPOOL 32a179a7347e4eeaaf0c4d9236fd0e566132dbd68ba7be1bb6f6711154617c23774cb2a14ef4365fd7726f61434789a2572889d98bd21c0eec61fbe966eab703
+DIST crypto-api-0.13.2.tar.gz 47877 SHA256 5331d511a9761d5073e6661148234228d88f8ace14e2994171f0bcf5183e82ed SHA512 2803862a714c3f448aa63469171fc68835ea9648a94d69ec76a32d20c1ed480aa3ecacedc3bf1e674797430c5d2966ceea4a83e38e827a68d2fab78fb4c8567c WHIRLPOOL ca6b625f1dedf3fb805affa911b148dab0d3897f9256b8056999eb3661c455f039d898eab6cb3b83ca73de9669393039be9d19db570c35a84b54dcf601d226b6
+DIST crypto-api-0.13.tar.gz 47884 SHA256 62f9eda6a2dc4a086eeefbb6f7b008d3f6e36bdd325f72858f4d43593d4bfc03 SHA512 f7bd7ae2eaeb7121cf03a3cd8ff6333d9ba5683efefaf79c11fea368f3a21afcf9f88695510906669e334b007c2329f0a507c169214e5a9828f272ec5afa9cb7 WHIRLPOOL e11f81debd53cc9a13c6aac26a05ac80d486eec036b95ca50e8577869fc679ede5947cf9e4dabb12da8db3dff6ba3bbd90dd066bfeb011ffbeea0cc71d5ad958
diff --git a/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild b/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
new file mode 100644
index 000000000000..56c5a6e0a272
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="all_cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all_cpolys all_cpolys)
+}
diff --git a/dev-haskell/crypto-api/crypto-api-0.13.2.ebuild b/dev-haskell/crypto-api/crypto-api-0.13.2.ebuild
new file mode 100644
index 000000000000..1755874c7dd5
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.13.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="all_cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all_cpolys all_cpolys)
+}
diff --git a/dev-haskell/crypto-api/crypto-api-0.13.ebuild b/dev-haskell/crypto-api/crypto-api-0.13.ebuild
new file mode 100644
index 000000000000..abfe3fdef173
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="all_cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all_cpolys all_cpolys)
+}
diff --git a/dev-haskell/crypto-api/metadata.xml b/dev-haskell/crypto-api/metadata.xml
new file mode 100644
index 000000000000..98a7f77a029b
--- /dev/null
+++ b/dev-haskell/crypto-api/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A generic interface for cryptographic operations (hashes, ciphers, randomness).
+ Maintainers of hash and cipher implementations are
+ encouraged to add instances for the classes defined
+ in Crypto.Classes. Crypto users are similarly
+ encouraged to use the interfaces defined in the Classes
+ module.
+ Any concepts or functions of general use to more than
+ one cryptographic algorithm (ex: padding) is within
+ scope of this package.
+ </longdescription>
+ <use>
+ <flag name="all_cpolys">Build all the CMAC polynomes up to 10000 bits instead of just the usual ones</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">TomMD/crypto-api</remote-id>
+ </upstream>
+</pkgmetadata>