summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:44:03 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:57:10 +0000
commitf70645b12d39bfff3a74ca23c4429f5004372dd8 (patch)
treed0e1ffd7bcf99872fb146637bff508092e779718 /dev-haskell/dav/dav-1.3.1.ebuild
parentdev-haskell/http-reverse-proxy: bump up to 0.4.3.2 (diff)
downloadgentoo-f70645b12d39bfff3a74ca23c4429f5004372dd8.tar.gz
gentoo-f70645b12d39bfff3a74ca23c4429f5004372dd8.tar.bz2
gentoo-f70645b12d39bfff3a74ca23c4429f5004372dd8.zip
dev-haskell/dav: bump up to 1.3.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/dav/dav-1.3.1.ebuild')
-rw-r--r--dev-haskell/dav/dav-1.3.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/dav/dav-1.3.1.ebuild b/dev-haskell/dav/dav-1.3.1.ebuild
new file mode 100644
index 000000000000..2c3a71e0a72d
--- /dev/null
+++ b/dev-haskell/dav/dav-1.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -mtl-compat
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="DAV"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="RFC 4918 WebDAV support"
+HOMEPAGE="http://floss.scru.org/hDAV"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/case-insensitive-0.4:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/exceptions-0.7:=[profile?]
+ dev-haskell/haskeline:=[profile?]
+ >=dev-haskell/http-client-0.4:=[profile?]
+ >=dev-haskell/http-client-tls-0.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lens-3.0:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?]
+ >=dev-haskell/optparse-applicative-0.10.0:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?]
+ >=dev-haskell/xml-hamlet-0.4:=[profile?] <dev-haskell/xml-hamlet-0.5:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-mtl-compat \
+ $(cabal_flag network-uri network-uri)
+}