summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild')
-rw-r--r--dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild b/dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild
new file mode 100644
index 000000000000..dae07a2f0fd2
--- /dev/null
+++ b/dev-haskell/dbus-core/dbus-core-0.9.3-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Low-level D-Bus protocol implementation"
+HOMEPAGE="https://john-millikin.com/software/dbus-core/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
+ >=dev-haskell/data-binary-ieee754-0.3:=[profile?] <dev-haskell/data-binary-ieee754-0.5:=[profile?]
+ =dev-haskell/libxml-sax-0.7*:=[profile?]
+ >=dev-haskell/network-2.2:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-0.11.1.5:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ =dev-haskell/xml-types-0.3*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ if has_version "<dev-haskell/haddock-2.9.2"; then
+ # Workaround http://hackage.haskell.org/trac/hackage/ticket/626
+ # The haddock --hoogle option does not like unicode characters, which causes
+ # haddock 2.7.2 to fail like:
+ # haddock: internal Haddock or GHC error: dist/doc/html/enumerator/enumerator.txt: commitAndReleaseBuffer: invalid argument (Invalid or incomplete multibyte or wide character)
+ sed -e 's@&#8208;@-@g' \
+ -e "s@&#8217;@'@g" \
+ -i "${S}/hs/DBus/Connection.hs" \
+ -i "${S}/hs/DBus/Client/Internal.hs" \
+ -i "${S}/hs/DBus/Client/Simple.hs" \
+ -i "${S}/hs/DBus/Message/Internal.hs" \
+ -i "${S}/hs/DBus/Types/Internal.hs" \
+ -i "${S}/hs/DBus/Wire/Internal.hs"
+ fi
+ cabal_chdeps \
+ 'binary >= 0.4 && < 0.6' 'binary >= 0.4' \
+ 'bytestring >= 0.9 && < 0.10' 'bytestring >= 0.9' \
+ 'containers >= 0.1 && < 0.5' 'containers >= 0.1' \
+ 'network >= 2.2 && < 2.4' 'network >= 2.2' \
+ 'text >= 0.11.1.5 && < 0.12' 'text >= 0.11.1.5' \
+ 'unix >= 2.2 && < 2.6' 'unix >= 2.2' \
+ 'vector >= 0.7 && < 0.10' 'vector >= 0.7'
+}