summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-01-16 22:13:37 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-01-16 22:14:31 +0000
commit6e904b116584cc22b6203d9205781f4572d91170 (patch)
treeb928c98e8722a98cbaf597eafde2b57896c85877 /dev-haskell/ed25519
parentnet-misc/networkmanager: Fix kernel .config checks (#605826 by Anton Bolshakov) (diff)
downloadgentoo-6e904b116584cc22b6203d9205781f4572d91170.tar.gz
gentoo-6e904b116584cc22b6203d9205781f4572d91170.tar.bz2
gentoo-6e904b116584cc22b6203d9205781f4572d91170.zip
dev-haskell/ed25519: new package, a depend of hackport
Ed25519 cryptographic signatures Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/ed25519')
-rw-r--r--dev-haskell/ed25519/Manifest1
-rw-r--r--dev-haskell/ed25519/ed25519-0.0.5.0.ebuild46
-rw-r--r--dev-haskell/ed25519/metadata.xml14
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/ed25519/Manifest b/dev-haskell/ed25519/Manifest
new file mode 100644
index 000000000000..16fafd5a1587
--- /dev/null
+++ b/dev-haskell/ed25519/Manifest
@@ -0,0 +1 @@
+DIST ed25519-0.0.5.0.tar.gz 80034 SHA256 d8a5958ebfa9309790efade64275dc5c441b568645c45ceed1b0c6ff36d6156d SHA512 cd2bb28de905c6d659f80f15e82970a9634c959432c73b6fd3b10ebca42a1ce734429e7ac861d0ab328904d99651a6d2fcaaf4d74ab75a3c0be68607e8f54ce9 WHIRLPOOL 92d51edd33d7209e2fed4c8cd4cf18127b16921b4676f3c5f1099a0ab64a0aa6aa6ddb67867e7e28bf489b480b67cd46f3ff29d1fe24b452ddb647c24bae0886
diff --git a/dev-haskell/ed25519/ed25519-0.0.5.0.ebuild b/dev-haskell/ed25519/ed25519-0.0.5.0.ebuild
new file mode 100644
index 000000000000..20c323029fd5
--- /dev/null
+++ b/dev-haskell/ed25519/ed25519-0.0.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: +no-donna,+test-doctests,+test-properties,-test-hlint
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Ed25519 cryptographic signatures"
+HOMEPAGE="http://thoughtpolice.github.com/hs-ed25519"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/doctest-0.10
+ >=dev-haskell/quickcheck-2.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'ghc-prim >= 0.1 && < 0.5' 'ghc-prim >= 0.1' \
+ 'doctest >= 0.10 && < 0.11' 'doctest >= 0.10' \
+ 'QuickCheck >= 2.4 && < 2.9' 'QuickCheck >= 2.4' \
+ 'directory >= 1.0 && < 1.3' 'directory >= 1.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=no-donna \
+ --flag=test-doctests \
+ --flag=-test-hlint \
+ --flag=test-properties
+}
diff --git a/dev-haskell/ed25519/metadata.xml b/dev-haskell/ed25519/metadata.xml
new file mode 100644
index 000000000000..af24f088297d
--- /dev/null
+++ b/dev-haskell/ed25519/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides a simple, fast, self-contained copy of the
+ Ed25519 public-key signature system with a clean interface. It also
+ includes support for detached signatures, and thorough documentation
+ on the design and implementation, including usage guidelines.
+ </longdescription>
+</pkgmetadata>