summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-07-19 08:02:41 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-07-19 08:03:40 +0100
commit16bd6ea96ff5d6acbbbc2d4542abe43d3735fa17 (patch)
tree04aab0f5c87b581b92e3002d00dc580fc31dc494 /dev-haskell/editline/editline-0.2.1.1-r1.ebuild
parentx11-misc/xwallpaper: drop 0.6.2 (diff)
downloadgentoo-16bd6ea96ff5d6acbbbc2d4542abe43d3735fa17.tar.gz
gentoo-16bd6ea96ff5d6acbbbc2d4542abe43d3735fa17.tar.bz2
gentoo-16bd6ea96ff5d6acbbbc2d4542abe43d3735fa17.zip
dev-haskell/editline: fix build against ncurses[tinfo], bug #689988
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/689988 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/editline/editline-0.2.1.1-r1.ebuild')
-rw-r--r--dev-haskell/editline/editline-0.2.1.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/editline/editline-0.2.1.1-r1.ebuild b/dev-haskell/editline/editline-0.2.1.1-r1.ebuild
new file mode 100644
index 000000000000..d235b4558327
--- /dev/null
+++ b/dev-haskell/editline/editline-0.2.1.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit autotools eutils haskell-cabal
+
+DESCRIPTION="Bindings to the editline library (libedit)"
+HOMEPAGE="http://code.haskell.org/editline"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+ dev-libs/libedit"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ghc-7.8.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoconf
+
+ cabal_chdeps \
+ 'base < 4.7' 'base'
+}