summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/errors
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/errors')
-rw-r--r--dev-haskell/errors/Manifest2
-rw-r--r--dev-haskell/errors/errors-1.4.5.ebuild28
-rw-r--r--dev-haskell/errors/errors-1.4.7.ebuild28
-rw-r--r--dev-haskell/errors/metadata.xml12
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-haskell/errors/Manifest b/dev-haskell/errors/Manifest
new file mode 100644
index 000000000000..fcf5768a2d57
--- /dev/null
+++ b/dev-haskell/errors/Manifest
@@ -0,0 +1,2 @@
+DIST errors-1.4.5.tar.gz 7575 SHA256 9854a63782d4130f5d5623f003210c142428eee53a43d1560a039410a6bea49a SHA512 ad5433a12455b9e94603d36888e2588bc65fd9dfb752e8641b4026e05b6f9aafd04504ff67c4fcb52a96be4ea55d0ed33279c22f8307cefac9daf4d47b550198 WHIRLPOOL e900d007abbc17140506e3dd927026374481642357b6c1a40cb7e0cab6fa7dae1e661a5b88888240a9b7a4ff1c957c23922224fad7ea71673d90dd06f28e2e24
+DIST errors-1.4.7.tar.gz 7922 SHA256 8732ebeae477feeb5b669532bc6ffc985f7b115e13fe823bbc816b4e7d1be525 SHA512 14873d32c744758000c6c8eb954aa659a57d78a32519d88e80e0f5b34a3f528e64293703da950475d89db2f79a7f2c80bc46a8824fee91cf3fe5668bda22a77c WHIRLPOOL 95f3171bf8c1f2701461180b8f42ef1344e7fbf116cfaf3257e68748935ad6b26c1db79f06fed4874ea8146345a38ce77c3a6b830d74abfad82e538556ed44ed
diff --git a/dev-haskell/errors/errors-1.4.5.ebuild b/dev-haskell/errors/errors-1.4.5.ebuild
new file mode 100644
index 000000000000..9d99d6ffc832
--- /dev/null
+++ b/dev-haskell/errors/errors-1.4.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simplified error-handling"
+HOMEPAGE="http://hackage.haskell.org/package/errors"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/either-3.1:=[profile?] <dev-haskell/either-5:=[profile?]
+ >=dev-haskell/safe-0.3.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/errors/errors-1.4.7.ebuild b/dev-haskell/errors/errors-1.4.7.ebuild
new file mode 100644
index 000000000000..a63a9eb55cf9
--- /dev/null
+++ b/dev-haskell/errors/errors-1.4.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simplified error-handling"
+HOMEPAGE="http://hackage.haskell.org/package/errors"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/either-3.1:=[profile?] <dev-haskell/either-5:=[profile?]
+ >=dev-haskell/safe-0.3.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/errors/metadata.xml b/dev-haskell/errors/metadata.xml
new file mode 100644
index 000000000000..be803d5677ff
--- /dev/null
+++ b/dev-haskell/errors/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The one-stop shop for all your error-handling needs! Just import
+ &quot;Control.Error&quot;.
+
+ This library encourages an error-handling style that directly uses the type
+ system, rather than out-of-band exceptions.
+ </longdescription>
+</pkgmetadata>