summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 11:03:51 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:02:14 +0100
commit36b7170c6062d77be6ae005dc395da6679f8b265 (patch)
tree591f1260efc2af62e116d09ba53403ac22a82bb2 /dev-haskell/exceptions/exceptions-0.10.4.ebuild
parentdev-haskell/casa-client: add package (diff)
downloadgentoo-36b7170c6062d77be6ae005dc395da6679f8b265.tar.gz
gentoo-36b7170c6062d77be6ae005dc395da6679f8b265.tar.bz2
gentoo-36b7170c6062d77be6ae005dc395da6679f8b265.zip
dev-haskell/exceptions: bump up to 0.10.4
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/exceptions/exceptions-0.10.4.ebuild')
-rw-r--r--dev-haskell/exceptions/exceptions-0.10.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/exceptions/exceptions-0.10.4.ebuild b/dev-haskell/exceptions/exceptions-0.10.4.ebuild
new file mode 100644
index 000000000000..073b42171f4b
--- /dev/null
+++ b/dev-haskell/exceptions/exceptions-0.10.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extensible optionally-pure exceptions"
+HOMEPAGE="https://github.com/ekmett/exceptions/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-3:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.7:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.10.1"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.5 && < 2.14' 'QuickCheck >= 2.5'
+}