summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:23:35 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:54 +0100
commit5642327506fc1c0959835c3a9ffbbd3d12593304 (patch)
tree5dd53ed0e5f0bbc340f8a8e5dbe50d1a7d7e59d3 /dev-haskell/feed/feed-1.3.0.1.ebuild
parentdev-haskell/http-conduit: bump up to 2.3.7.3 (diff)
downloadgentoo-5642327506fc1c0959835c3a9ffbbd3d12593304.tar.gz
gentoo-5642327506fc1c0959835c3a9ffbbd3d12593304.tar.bz2
gentoo-5642327506fc1c0959835c3a9ffbbd3d12593304.zip
dev-haskell/feed: bump up to 1.3.0.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/feed/feed-1.3.0.1.ebuild')
-rw-r--r--dev-haskell/feed/feed-1.3.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/feed/feed-1.3.0.1.ebuild b/dev-haskell/feed/feed-1.3.0.1.ebuild
new file mode 100644
index 000000000000..909b96ff32b8
--- /dev/null
+++ b/dev-haskell/feed/feed-1.3.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # markdown-unlit fals to generate a test: "test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
+HOMEPAGE="https://github.com/bergmark/feed"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # ghc: could not execute: markdown-unlit
+
+RDEPEND=">=dev-haskell/base-compat-0.9:=[profile?] <dev-haskell/base-compat-0.12:=[profile?]
+ >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/old-time-1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
+ <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/xml-conduit-1.3:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
+ >=dev-haskell/xml-types-0.3.6:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4 && < 4.14' 'base >= 4'
+}