summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-21 08:37:39 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-21 08:40:24 +0100
commitd8c7a219a11681d908a587c687872566cb7bf34c (patch)
tree1d65a2bdb97d75b445036045f6697a3459a99529 /dev-haskell/ghc-lib-parser-ex/ghc-lib-parser-ex-8.10.0.19.ebuild
parentdev-haskell/ghc-lib-parser: new package, a depend of hlint-3 (diff)
downloadgentoo-d8c7a219a11681d908a587c687872566cb7bf34c.tar.gz
gentoo-d8c7a219a11681d908a587c687872566cb7bf34c.tar.bz2
gentoo-d8c7a219a11681d908a587c687872566cb7bf34c.zip
dev-haskell/ghc-lib-parser-ex: new package, a depend of hlint-3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/ghc-lib-parser-ex/ghc-lib-parser-ex-8.10.0.19.ebuild')
-rw-r--r--dev-haskell/ghc-lib-parser-ex/ghc-lib-parser-ex-8.10.0.19.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/ghc-lib-parser-ex/ghc-lib-parser-ex-8.10.0.19.ebuild b/dev-haskell/ghc-lib-parser-ex/ghc-lib-parser-ex-8.10.0.19.ebuild
new file mode 100644
index 000000000000..8df43a19e93f
--- /dev/null
+++ b/dev-haskell/ghc-lib-parser-ex/ghc-lib-parser-ex-8.10.0.19.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -no-ghc-lib,+auto
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Algorithms on GHC parse trees"
+HOMEPAGE="https://github.com/shayne-fletcher/ghc-lib-parser-ex#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/ghc-lib-parser-8.10:=[profile?] <dev-haskell/ghc-lib-parser-8.11:=[profile?]
+ >=dev-haskell/uniplate-1.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/extra-1.6
+ >=dev-haskell/tasty-1.2
+ >=dev-haskell/tasty-hunit-0.10.0
+ >=dev-haskell/uniplate-1.6.12 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=auto \
+ --flag=-no-ghc-lib
+}