summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:57:41 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:23 +0100
commite435eac07d18035f5fbd6dd0118a8ec33ce22d44 (patch)
treebe73e9dba760072518b8550794823c5f1385372c /dev-haskell/ghc-paths
parentdev-haskell/haddock-library: bump up to 1.8.0 (diff)
downloadgentoo-e435eac07d18035f5fbd6dd0118a8ec33ce22d44.tar.gz
gentoo-e435eac07d18035f5fbd6dd0118a8ec33ce22d44.tar.bz2
gentoo-e435eac07d18035f5fbd6dd0118a8ec33ce22d44.zip
dev-haskell/ghc-paths: bump up to 0.1.0.12
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/ghc-paths')
-rw-r--r--dev-haskell/ghc-paths/Manifest1
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/ghc-paths/Manifest b/dev-haskell/ghc-paths/Manifest
index 92f2b6d8037a..4d0a8e403c55 100644
--- a/dev-haskell/ghc-paths/Manifest
+++ b/dev-haskell/ghc-paths/Manifest
@@ -1 +1,2 @@
+DIST ghc-paths-0.1.0.12.tar.gz 2565 BLAKE2B 3e4783a854510a4ae6d6a9d5f4d0fefa7fbc03088aa298d8731c7bdf961ab47553b0e46c1b8d2f61193b669c43fc74e8eb6f948abba4419b0110772d56397c1d SHA512 1c66caf459f5783bde38a47ce1292bf5c47fef21e3f69d7f6c052b4eb39f446ed5decd38f0e4143a90d55ba44ebc0891b4497050cc652cbf3fcad636d45690e9
DIST ghc-paths-0.1.0.9.tar.gz 2402 BLAKE2B ba84e058a09fabe4b386120855966daeef0d71e0ccc4f131cacdd12cfe064c415715ef3dcbc33a1c5f0e5339f58d61b37d8842c2ca0f97245f56926716bf834b SHA512 0aa38add4a6f27ced115d769603f98eff6fe3e8b60a6477f4b1e669031cbb6408b87d2fed023d790169b623b9cb2b7983871a9bf9d5cfcc298774a34808e2094
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
new file mode 100644
index 000000000000..bfe1e0199186
--- /dev/null
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2.9999
+
+# haddock feature is explicitely disabled, as this library can be used as haddock depend
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Knowledge of GHC's installation directories"
+HOMEPAGE="http://hackage.haskell.org/package/ghc-paths"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6 <dev-haskell/cabal-3.3
+"
+
+src_prepare() {
+ default
+ # ghc-patch it has awfully unportable (across cabal versions) ghc detection code
+ # but in gentoo we install it to fixed patch, so remove Setup.hs detection code
+ cabal-mksetup
+
+ cabal_chdeps \
+ 'Cabal >= 1.6 && <3.1' 'Cabal >= 1.6 && <3.3'
+
+ # and use gentoo's hardcoded one:
+ # a few things we need to replace, and example values
+ # GHC_PATHS_LIBDIR /usr/lib64/ghc-6.12.0.20091010
+ # GHC_PATHS_DOCDIR /usr/share/doc/ghc-6.12.0.20091010/html
+ # GHC_PATHS_GHC_PKG /usr/bin/ghc-pkg
+ # GHC_PATHS_GHC /usr/bin/ghc (be careful: GHC_PATHS_GHC is a substring of GHC_PATHS_GHC_PKG)
+
+ cat >"${S}/GHC/Paths.hs" <<-EOF
+ module GHC.Paths ( ghc, ghc_pkg, libdir, docdir ) where
+
+ libdir, docdir, ghc, ghc_pkg :: FilePath
+
+ libdir = "$(ghc-libdir)"
+ docdir = "/usr/share/doc/ghc-$(ghc-version)/html"
+
+ ghc = "$(ghc-getghc)"
+ ghc_pkg = "$(ghc-getghcpkg)"
+ EOF
+}