summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:47:58 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:50:57 +0100
commit0a012c7f06bd5ed4cb33d7fcfd43acd34de9abf8 (patch)
treeb9ee82ef39ffbe5c10b92990b3f7dc8395997e06 /dev-haskell/git/git-0.3.0.ebuild
parentprofiles/targets/desktop: Enable gui flag. (diff)
downloadgentoo-0a012c7f06bd5ed4cb33d7fcfd43acd34de9abf8.tar.gz
gentoo-0a012c7f06bd5ed4cb33d7fcfd43acd34de9abf8.tar.bz2
gentoo-0a012c7f06bd5ed4cb33d7fcfd43acd34de9abf8.zip
dev-haskell/git: new package, a depend of hit-0.7.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/git/git-0.3.0.ebuild')
-rw-r--r--dev-haskell/git/git-0.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/git/git-0.3.0.ebuild b/dev-haskell/git/git-0.3.0.ebuild
new file mode 100644
index 000000000000..521fbe6b0456
--- /dev/null
+++ b/dev-haskell/git/git-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Git operations in haskell"
+HOMEPAGE="https://github.com/vincenthz/hs-git"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/basement:=[profile?]
+ >=dev-haskell/cryptonite-0.22:=[profile?]
+ >=dev-haskell/hourglass-0.2:=[profile?]
+ >=dev-haskell/memory-0.13:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/system-fileio:=[profile?]
+ dev-haskell/system-filepath:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/bytedump-1.0
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+
+PATCHES=( "${FILESDIR}/${P}-monadfail.patch" )