summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-09-05 18:43:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-09-05 18:44:01 +0100
commite0579eeea3518dc826078f7622085405c1429299 (patch)
treed168ef03e03ce316ceb32597b954f1f0bc41700f /dev-haskell/glib/glib-0.13.2.1.ebuild
parentx11-misc/colord: Drop old (diff)
downloadgentoo-e0579eeea3518dc826078f7622085405c1429299.tar.gz
gentoo-e0579eeea3518dc826078f7622085405c1429299.tar.bz2
gentoo-e0579eeea3518dc826078f7622085405c1429299.zip
dev-haskell/glib: bump up to 0.13.2.1
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-haskell/glib/glib-0.13.2.1.ebuild')
-rw-r--r--dev-haskell/glib/glib-0.13.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/glib/glib-0.13.2.1.ebuild b/dev-haskell/glib/glib-0.13.2.1.ebuild
new file mode 100644
index 000000000000..6287f65782c0
--- /dev/null
+++ b/dev-haskell/glib/glib-0.13.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+closure_signals"
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18
+ dev-haskell/gtk2hs-buildtools
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closure_signals closure_signals)
+}