summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 18:36:12 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commitc0c09ee7c5eb674759b212e5e86fd410575edb0c (patch)
tree53464ebbe823a7be16a52bb315d2e3a7acd70510 /dev-haskell/glib/glib-0.13.2.2.ebuild
parentdev-haskell/gio: bump up to 0.13.1.1 (diff)
downloadgentoo-c0c09ee7c5eb674759b212e5e86fd410575edb0c.tar.gz
gentoo-c0c09ee7c5eb674759b212e5e86fd410575edb0c.tar.bz2
gentoo-c0c09ee7c5eb674759b212e5e86fd410575edb0c.zip
dev-haskell/glib: bump up to 0.13.2.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/glib/glib-0.13.2.2.ebuild')
-rw-r--r--dev-haskell/glib/glib-0.13.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/glib/glib-0.13.2.2.ebuild b/dev-haskell/glib/glib-0.13.2.2.ebuild
new file mode 100644
index 000000000000..6287f65782c0
--- /dev/null
+++ b/dev-haskell/glib/glib-0.13.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+closure_signals"
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18
+ dev-haskell/gtk2hs-buildtools
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closure_signals closure_signals)
+}