summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 22:29:08 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 22:53:44 +0000
commit2ea3be2123f2c832a47c690a33448133ca433769 (patch)
tree238bb4eb083c7f6a0b3b889716215028bdd8c8fd /dev-haskell/glib/glib-0.13.7.0.ebuild
parentdev-haskell/gluraw: bump up to 2.0.0.4 (diff)
downloadgentoo-2ea3be2123f2c832a47c690a33448133ca433769.tar.gz
gentoo-2ea3be2123f2c832a47c690a33448133ca433769.tar.bz2
gentoo-2ea3be2123f2c832a47c690a33448133ca433769.zip
dev-haskell/glib: bump up to 0.13.7.0
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/glib/glib-0.13.7.0.ebuild')
-rw-r--r--dev-haskell/glib/glib-0.13.7.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/glib/glib-0.13.7.0.ebuild b/dev-haskell/glib/glib-0.13.7.0.ebuild
new file mode 100644
index 000000000000..5ea50c20e5bf
--- /dev/null
+++ b/dev-haskell/glib/glib-0.13.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+closure-signals"
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24 <dev-haskell/cabal-3.1
+ >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.24 && < 2.5' 'Cabal >= 1.24 && < 3.1'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closure-signals closure_signals)
+}