summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/haddock-library
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/haddock-library')
-rw-r--r--dev-haskell/haddock-library/Manifest2
-rw-r--r--dev-haskell/haddock-library/haddock-library-1.1.1.ebuild28
-rw-r--r--dev-haskell/haddock-library/haddock-library-1.2.1.ebuild29
-rw-r--r--dev-haskell/haddock-library/metadata.xml13
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-haskell/haddock-library/Manifest b/dev-haskell/haddock-library/Manifest
new file mode 100644
index 000000000000..4d6393aae5e9
--- /dev/null
+++ b/dev-haskell/haddock-library/Manifest
@@ -0,0 +1,2 @@
+DIST haddock-library-1.1.1.tar.gz 35641 SHA256 350c2dd4f62fc85debe53ea51ce2a7e8ec7c8abb1b5acc664c5adf80ebaa566a SHA512 5f1a592af66a054482fc06ca8d974db0ebd4e42b383ec6b3fd7d44d155bd89c567013af1266e697b76a96b4d39486bc22eac7eb4b1d6842ec0f842533ac8dffb WHIRLPOOL 7e8020b0ae5200b97f5f568bc82e68c1f8379c86291c37b4fd6ec73890b7ba22aa3a74c496267912b51ccc862d208ff021614886cdf045692dd098733186bb34
+DIST haddock-library-1.2.1.tar.gz 38606 SHA256 0fb1a09d2b6f5339bc008a8ebf6519f22d27f65cfcc682488a7b67e8ee151056 SHA512 7ac9dfc648e6e59e1dbaafc7fdf26acb378997506c353dedadf89a729223cdb518edd59642e81758fd898cda163258e5e4150fc84369c3e011e59acd827a037a WHIRLPOOL 67a48f606d9a55079796fd2ad75e9e8a5e4b183c6d98653ffc81fa5678ddf551f48104f067809ce91e4807db35b0475f46d0a4d5f8f252ef7eb273a52ef9176e
diff --git a/dev-haskell/haddock-library/haddock-library-1.1.1.ebuild b/dev-haskell/haddock-library/haddock-library-1.1.1.ebuild
new file mode 100644
index 000000000000..900f8fe3a624
--- /dev/null
+++ b/dev-haskell/haddock-library/haddock-library-1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library exposing some functionality of Haddock"
+HOMEPAGE="http://www.haskell.org/haddock/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/base-compat
+ dev-haskell/hspec
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3 )
+"
diff --git a/dev-haskell/haddock-library/haddock-library-1.2.1.ebuild b/dev-haskell/haddock-library/haddock-library-1.2.1.ebuild
new file mode 100644
index 000000000000..bcfad0a0b63f
--- /dev/null
+++ b/dev-haskell/haddock-library/haddock-library-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library exposing some functionality of Haddock"
+HOMEPAGE="http://www.haskell.org/haddock/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/base-compat
+ dev-haskell/hspec
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3 )
+"
diff --git a/dev-haskell/haddock-library/metadata.xml b/dev-haskell/haddock-library/metadata.xml
new file mode 100644
index 000000000000..fd7337622322
--- /dev/null
+++ b/dev-haskell/haddock-library/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Haddock is a documentation-generation tool for Haskell
+ libraries. These modules expose some functionality of it
+ without pulling in the GHC dependency. Please note that the
+ API is likely to change so specify upper bounds in your
+ project if you can&#39;t release often. For interacting with Haddock
+ itself, see the <pkg>dev-haskell/haddock</pkg> package.
+ </longdescription>
+</pkgmetadata>