summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 21:10:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 21:27:11 +0000
commitaf55cdda8c96c3a0ab9235fb36f9b6e1c8e6fd6a (patch)
treeaab284e6f3a396db091d3893d1faca129e7da8a7 /dev-haskell/hashable/hashable-1.2.7.0.ebuild
parentdev-haskell/hashable-time: bump up to 0.2.0.2 (diff)
downloadgentoo-af55cdda8c96c3a0ab9235fb36f9b6e1c8e6fd6a.tar.gz
gentoo-af55cdda8c96c3a0ab9235fb36f9b6e1c8e6fd6a.tar.bz2
gentoo-af55cdda8c96c3a0ab9235fb36f9b6e1c8e6fd6a.zip
dev-haskell/hashable: bump up to 1.2.7.0
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hashable/hashable-1.2.7.0.ebuild')
-rw-r--r--dev-haskell/hashable/hashable-1.2.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/hashable/hashable-1.2.7.0.ebuild b/dev-haskell/hashable/hashable-1.2.7.0.ebuild
new file mode 100644
index 000000000000..6ccc1e3185a3
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+#hackport: flags: sse41:cpu_flags_x86_sse4_1,sse2:cpu_flags_x86_sse2,integer-gmp:gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Drop test-suite: circular depend
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="https://github.com/tibbe/hashable"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 examples +gmp"
+
+RESTRICT=test # circular deps: hashable[test]->quickcheck->semigroups->hashable
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.4 && < 4.12' 'base >= 4.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ $(cabal_flag gmp integer-gmp) \
+ $(cabal_flag cpu_flags_x86_sse2 sse2) \
+ $(cabal_flag cpu_flags_x86_sse4_1 sse41)
+}