summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:37:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:38:13 +0100
commit346697420ffcb442cf97c41687c31a9b4bbf6e0d (patch)
treebfb747bb36dbafb02a803550eb2c02c1abb566fa /dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild
parentdev-python/hypothesis: Bump to 5.26.1 (diff)
downloadgentoo-346697420ffcb442cf97c41687c31a9b4bbf6e0d.tar.gz
gentoo-346697420ffcb442cf97c41687c31a9b4bbf6e0d.tar.bz2
gentoo-346697420ffcb442cf97c41687c31a9b4bbf6e0d.zip
dev-haskell/hdbc-odbc: bump up to 2.6.0.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild')
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild
new file mode 100644
index 000000000000..d0afebe0c643
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -buildtests,-buildstresstest
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-odbc"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ODBC driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-odbc"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/unixODBC
+ >=dev-haskell/concurrent-extra-0.7.0.8:=[profile?]
+ >=dev-haskell/hdbc-2.1.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ virtual/libc
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-buildstresstest \
+ --flag=-buildtests
+}