summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-03-25 18:56:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-03-25 19:07:56 +0000
commit07ecabef92ad21cf9e12af3c1bc97d582d207094 (patch)
tree270ddca6774cbf48fcec232f073ae21c0b0f3838 /dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
parentdev-haskell/hdbc-sqlite: drop unused files/ (diff)
downloadgentoo-07ecabef92ad21cf9e12af3c1bc97d582d207094.tar.gz
gentoo-07ecabef92ad21cf9e12af3c1bc97d582d207094.tar.bz2
gentoo-07ecabef92ad21cf9e12af3c1bc97d582d207094.zip
dev-haskell/hdbc-sqlite3: move package from dev-haskell/hdbc-sqlite:2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild')
-rw-r--r--dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
new file mode 100644
index 000000000000..696da308bffe
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-sqlite3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sqlite v3 driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-sqlite3"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="buildtests +splitbase"
+
+RDEPEND=">=dev-db/sqlite-3.0
+ >=dev-haskell/hdbc-2.3.0.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ buildtests? ( dev-haskell/convertible:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildtests buildtests) \
+ $(cabal_flag splitbase splitbase)
+}