summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-10 22:58:47 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commit495086f4a4856bef953147e17c8121d7cf1eaf26 (patch)
tree86f3e01a3f78064c7441c89391b187ac51127a71 /dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild
parentdev-haskell/hostname: fix DESCRIPTION length (diff)
downloadgentoo-495086f4a4856bef953147e17c8121d7cf1eaf26.tar.gz
gentoo-495086f4a4856bef953147e17c8121d7cf1eaf26.tar.bz2
gentoo-495086f4a4856bef953147e17c8121d7cf1eaf26.zip
dev-haskell/highlighting-kate: bump up to 0.6.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild')
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild
new file mode 100644
index 000000000000..47a08eddf575
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="https://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.9:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
+ !pcre-light? ( >=dev-haskell/regex-pcre-builtin-0.94.4.8.8.35:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/diff )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}