summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:16:05 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:23:11 +0000
commit0906414fae93d2e4fcc8e2f7195c458d287dabfa (patch)
treef97c0f01c1e52f822d9159d960210384f6b0fc6c /dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild
parentdev-haskell/haskell-lexer: bump up to 1.0.1 (diff)
downloadgentoo-0906414fae93d2e4fcc8e2f7195c458d287dabfa.tar.gz
gentoo-0906414fae93d2e4fcc8e2f7195c458d287dabfa.tar.bz2
gentoo-0906414fae93d2e4fcc8e2f7195c458d287dabfa.zip
dev-haskell/highlighting-kate: bump up to 0.6.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild')
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild
new file mode 100644
index 000000000000..161199f69017
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="https://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.9:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
+ !pcre-light? ( >=dev-haskell/regex-pcre-builtin-0.94.4.8.8.35:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/diff )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}