summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:48:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:50:57 +0100
commit3abfa4217842607a76e36aed1ce7db631d4e6eb0 (patch)
tree8a53b2abc525b1fe713532533aeb2afa8c6f870e /dev-haskell/hit/hit-0.7.0.ebuild
parentdev-haskell/git: new package, a depend of hit-0.7.0 (diff)
downloadgentoo-3abfa4217842607a76e36aed1ce7db631d4e6eb0.tar.gz
gentoo-3abfa4217842607a76e36aed1ce7db631d4e6eb0.tar.bz2
gentoo-3abfa4217842607a76e36aed1ce7db631d4e6eb0.zip
dev-haskell/hit: bump up to 0.7.0
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/736020 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hit/hit-0.7.0.ebuild')
-rw-r--r--dev-haskell/hit/hit-0.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/hit/hit-0.7.0.ebuild b/dev-haskell/hit/hit-0.7.0.ebuild
new file mode 100644
index 000000000000..f5754a04b7a8
--- /dev/null
+++ b/dev-haskell/hit/hit-0.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES=""
+inherit haskell-cabal
+
+DESCRIPTION="Git operations in haskell"
+HOMEPAGE="https://github.com/vincenthz/hit"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-haskell/git-0.3.0:=
+ >=dev-haskell/hashable-1.2:=
+ dev-haskell/hashtables:=
+ dev-haskell/hourglass:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}