summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 14:07:20 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 14:17:43 +0100
commit91238e04f1c881821c1ff6349fa5d37aa5d820ce (patch)
tree39d99e1547541c418e0cc035d4da6ddb9bd29630 /dev-haskell/hlint/hlint-1.9.35.ebuild
parentdev-haskell/refact: apply refactors, a depend of dev-haskell/hlint (diff)
downloadgentoo-91238e04f1c881821c1ff6349fa5d37aa5d820ce.tar.gz
gentoo-91238e04f1c881821c1ff6349fa5d37aa5d820ce.tar.bz2
gentoo-91238e04f1c881821c1ff6349fa5d37aa5d820ce.zip
dev-haskell/hlint: bump up to 1.9.35
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-haskell/hlint/hlint-1.9.35.ebuild')
-rw-r--r--dev-haskell/hlint/hlint-1.9.35.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/hlint/hlint-1.9.35.ebuild b/dev-haskell/hlint/hlint-1.9.35.ebuild
new file mode 100644
index 000000000000..9ca244d7f1f2
--- /dev/null
+++ b/dev-haskell/hlint/hlint-1.9.35.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal elisp-common
+
+DESCRIPTION="Source code suggestions"
+HOMEPAGE="https://github.com/ndmitchell/hlint#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +gpl"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
+ >=dev-haskell/cmdargs-0.10:=[profile?]
+ >=dev-haskell/cpphs-1.20.1:=[profile?]
+ >=dev-haskell/extra-1.4.9:2=[profile?]
+ >=dev-haskell/haskell-src-exts-1.17:=[profile?] <dev-haskell/haskell-src-exts-1.18:=[profile?]
+ >=dev-haskell/refact-0.3:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/uniplate-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ gpl? ( >=dev-haskell/hscolour-1.21:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_configure() {
+ local threaded_flag=""
+ if $(ghc-supports-threaded-runtime); then
+ threaded_flag="--flags=threaded"
+ else
+ threaded_flag="--flags=-threaded"
+ fi
+
+ haskell-cabal_src_configure \
+ $(cabal_flag gpl gpl) \
+ $threaded_flag
+}
+
+src_compile() {
+ cabal_src_compile
+
+ use emacs && elisp-compile data/hs-lint.el
+}
+
+src_install() {
+ cabal_src_install
+
+ if use emacs; then
+ elisp-install ${PN} data/*.el data/*.elc || die "elisp-install failed."
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ doman data/hlint.1
+}
+
+pkg_postinst() {
+ haskell-cabal_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ haskell-cabal_pkg_postrm
+ use emacs && elisp-site-regen
+}