summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 18:41:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit43afd43b0168be4cf0e86d913f9e521b647736a3 (patch)
tree8e903957ff76b591e2dc78bcd3deb8f724c3872c /dev-haskell/hscolour/hscolour-1.23-r1.ebuild
parentdev-haskell/hjsmin: bump up to 0.1.5.1 (diff)
downloadgentoo-43afd43b0168be4cf0e86d913f9e521b647736a3.tar.gz
gentoo-43afd43b0168be4cf0e86d913f9e521b647736a3.tar.bz2
gentoo-43afd43b0168be4cf0e86d913f9e521b647736a3.zip
dev-haskell/hscolour: bump up to 1.23
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/hscolour/hscolour-1.23-r1.ebuild')
-rw-r--r--dev-haskell/hscolour/hscolour-1.23-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/hscolour/hscolour-1.23-r1.ebuild b/dev-haskell/hscolour/hscolour-1.23-r1.ebuild
new file mode 100644
index 000000000000..de818018461a
--- /dev/null
+++ b/dev-haskell/hscolour/hscolour-1.23-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Colourise Haskell code"
+HOMEPAGE="http://code.haskell.org/~malcolm/hscolour/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ # llvm-general-pure passes rtsopts
+ haskell-cabal_src_configure --ghc-options=-rtsopts
+}
+
+src_install() {
+ cabal_src_install
+ if use doc; then
+ dohtml hscolour.css
+ fi
+}