summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/hspec-core
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/hspec-core')
-rw-r--r--dev-haskell/hspec-core/hspec-core-2.1.2.ebuild4
-rw-r--r--dev-haskell/hspec-core/hspec-core-2.1.4.ebuild4
-rw-r--r--dev-haskell/hspec-core/hspec-core-2.2.1.ebuild4
-rw-r--r--dev-haskell/hspec-core/hspec-core-2.2.4.ebuild4
4 files changed, 8 insertions, 8 deletions
diff --git a/dev-haskell/hspec-core/hspec-core-2.1.2.ebuild b/dev-haskell/hspec-core/hspec-core-2.1.2.ebuild
index f32b184383e3..b16ef88e2f0a 100644
--- a/dev-haskell/hspec-core/hspec-core-2.1.2.ebuild
+++ b/dev-haskell/hspec-core/hspec-core-2.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="A Testing Framework for Haskell"
HOMEPAGE="http://hspec.github.io/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
diff --git a/dev-haskell/hspec-core/hspec-core-2.1.4.ebuild b/dev-haskell/hspec-core/hspec-core-2.1.4.ebuild
index 71acb66b965a..c530b6a6c4d8 100644
--- a/dev-haskell/hspec-core/hspec-core-2.1.4.ebuild
+++ b/dev-haskell/hspec-core/hspec-core-2.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="A Testing Framework for Haskell"
HOMEPAGE="http://hspec.github.io/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
diff --git a/dev-haskell/hspec-core/hspec-core-2.2.1.ebuild b/dev-haskell/hspec-core/hspec-core-2.2.1.ebuild
index f9ce1a1d3e69..4d0021b0552d 100644
--- a/dev-haskell/hspec-core/hspec-core-2.2.1.ebuild
+++ b/dev-haskell/hspec-core/hspec-core-2.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="A Testing Framework for Haskell"
HOMEPAGE="http://hspec.github.io/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
diff --git a/dev-haskell/hspec-core/hspec-core-2.2.4.ebuild b/dev-haskell/hspec-core/hspec-core-2.2.4.ebuild
index a3c56d7c3ce5..4d7b7c24f158 100644
--- a/dev-haskell/hspec-core/hspec-core-2.2.4.ebuild
+++ b/dev-haskell/hspec-core/hspec-core-2.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="A Testing Framework for Haskell"
HOMEPAGE="http://hspec.github.io/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"