summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-24 15:34:28 -0400
committerSam James <sam@gentoo.org>2022-07-30 06:58:01 +0100
commitc4819c04c4a6b32f68977a2e10ffa997d16e06e0 (patch)
tree1866fa1866885afdd87d9b6d7c012ea85e9f24b3 /dev-haskell/httpd-shed
parentdev-haskell/hackage-security: keyword 0.6.1.0 for ~ppc64 (diff)
downloadgentoo-c4819c04c4a6b32f68977a2e10ffa997d16e06e0.tar.gz
gentoo-c4819c04c4a6b32f68977a2e10ffa997d16e06e0.tar.bz2
gentoo-c4819c04c4a6b32f68977a2e10ffa997d16e06e0.zip
dev-haskell/httpd-shed: revbump 0.4.1.1-r1
https://github.com/gentoo-haskell/gentoo-haskell/commit/35f0da0b8a079defb9391dbb220fe6a7932e1cc8 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/httpd-shed')
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild34
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4.1.1.ebuild40
-rw-r--r--dev-haskell/httpd-shed/metadata.xml2
3 files changed, 34 insertions, 42 deletions
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild
new file mode 100644
index 000000000000..25e4e5f39a23
--- /dev/null
+++ b/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+#hackport: flags: +network-uri,+network-bsd
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple web-server with an interact style API"
+HOMEPAGE="https://hackage.haskell.org/package/httpd-shed"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="buildexamples"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-bsd-2.7:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildexamples buildexamples) \
+ --flag=network-bsd \
+ --flag=network-uri
+}
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4.1.1.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4.1.1.ebuild
deleted file mode 100644
index 887a309bcd6a..000000000000
--- a/dev-haskell/httpd-shed/httpd-shed-0.4.1.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="A simple web-server with an interact style API"
-HOMEPAGE="https://hackage.haskell.org/package/httpd-shed"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="buildexamples +network-bsd +network-uri"
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
- >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?]
- >=dev-haskell/network-uri-2.5:=[profile?] <dev-haskell/network-uri-2.7:=[profile?]
- network-bsd? ( >=dev-haskell/network-bsd-2.7:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
- >=dev-haskell/network-2.7:=[profile?] )
- !network-bsd? ( <dev-haskell/network-2.7:=[profile?] )
- network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?]
- >=dev-haskell/network-2.6:=[profile?] )
- !network-uri? ( <dev-haskell/network-2.6:=[profile?]
- <dev-haskell/network-uri-2.6:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag buildexamples buildexamples) \
- $(cabal_flag network-bsd network-bsd) \
- $(cabal_flag network-uri network-uri)
-}
diff --git a/dev-haskell/httpd-shed/metadata.xml b/dev-haskell/httpd-shed/metadata.xml
index 7a2c9f5d6382..e8d6b06231be 100644
--- a/dev-haskell/httpd-shed/metadata.xml
+++ b/dev-haskell/httpd-shed/metadata.xml
@@ -12,7 +12,5 @@
</longdescription>
<use>
<flag name="buildexamples">Build example executables.</flag>
- <flag name="network-uri">Get Network.URI from the network-uri package.</flag>
- <flag name="network-bsd">Get Network.BSD from the network-bsd package.</flag>
</use>
</pkgmetadata>