summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-12-09 13:34:03 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-12-09 13:53:24 +0000
commit7b4d6e4cdce07fab1e408ae8a15e8b98ddb5ad7d (patch)
treee8e263bf3d26390c182212cdf52d5bed6a95dc0e /dev-haskell/language-c/language-c-0.7.1.ebuild
parentmedia-video/avidemux: Drop USE=qt4 (diff)
downloadgentoo-7b4d6e4cdce07fab1e408ae8a15e8b98ddb5ad7d.tar.gz
gentoo-7b4d6e4cdce07fab1e408ae8a15e8b98ddb5ad7d.tar.bz2
gentoo-7b4d6e4cdce07fab1e408ae8a15e8b98ddb5ad7d.zip
dev-haskell/language-c: bump up to 0.7.1, bug #637496
Bug: https://bugs.gentoo.org/637496 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-haskell/language-c/language-c-0.7.1.ebuild')
-rw-r--r--dev-haskell/language-c/language-c-0.7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/language-c/language-c-0.7.1.ebuild b/dev-haskell/language-c/language-c-0.7.1.ebuild
new file mode 100644
index 000000000000..a7a347b3ae82
--- /dev/null
+++ b/dev-haskell/language-c/language-c-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4.9999
+#hackport: flags: -allwarnings,+usebytestrings
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Analysis and generation of C code"
+HOMEPAGE="http://visq.github.io/language-c/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/syb:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.8
+ dev-haskell/happy
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-allwarnings \
+ --flag=usebytestrings
+}