summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/lcs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/lcs')
-rw-r--r--dev-haskell/lcs/Manifest1
-rw-r--r--dev-haskell/lcs/files/lcs-0.2-ghc-7.10.patch8
-rw-r--r--dev-haskell/lcs/lcs-0.2-r1.ebuild29
-rw-r--r--dev-haskell/lcs/lcs-0.2.ebuild23
-rw-r--r--dev-haskell/lcs/metadata.xml24
5 files changed, 85 insertions, 0 deletions
diff --git a/dev-haskell/lcs/Manifest b/dev-haskell/lcs/Manifest
new file mode 100644
index 000000000000..4a6af7becd3d
--- /dev/null
+++ b/dev-haskell/lcs/Manifest
@@ -0,0 +1 @@
+DIST lcs-0.2.tar.gz 11638 SHA256 b4db67ead4e2f58c4d462d4c1006d2158744ef3ca8597295a1dfa08537401ff1 SHA512 ac5ac6d9a151be46054f2f56a5927182fe6942e518a04a8c484b02c8caec0506ddaf846f51f5575f1f30d6f0fca9b7b26f16e32675b322d014f8b68db76d5f5e WHIRLPOOL 1b210507fe1298b2b67caa496cedbe549923302d74aab51fe4eb2dae5fc0d0867099b4dbcd73eb733ca359decfcacd2e84046f6dee10034e973c7209ce30bb8f
diff --git a/dev-haskell/lcs/files/lcs-0.2-ghc-7.10.patch b/dev-haskell/lcs/files/lcs-0.2-ghc-7.10.patch
new file mode 100644
index 000000000000..24165ffb9104
--- /dev/null
+++ b/dev-haskell/lcs/files/lcs-0.2-ghc-7.10.patch
@@ -0,0 +1,8 @@
+diff --git a/Data/List/LCS/HuntSzymanski.hs b/Data/List/LCS/HuntSzymanski.hs
+index 306368f..e9df4ef 100644
+--- a/Data/List/LCS/HuntSzymanski.hs
++++ b/Data/List/LCS/HuntSzymanski.hs
+@@ -1,2 +1,2 @@
+-
++{-# LANGUAGE FlexibleContexts #-}
+ -----------------------------------------------------------------------------
diff --git a/dev-haskell/lcs/lcs-0.2-r1.ebuild b/dev-haskell/lcs/lcs-0.2-r1.ebuild
new file mode 100644
index 000000000000..2271036c5592
--- /dev/null
+++ b/dev-haskell/lcs/lcs-0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Find longest common sublist of two lists"
+HOMEPAGE="http://urchin.earth.li/~ian/cabal/lcs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/cabal
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}
diff --git a/dev-haskell/lcs/lcs-0.2.ebuild b/dev-haskell/lcs/lcs-0.2.ebuild
new file mode 100644
index 000000000000..06562460b95f
--- /dev/null
+++ b/dev-haskell/lcs/lcs-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Find longest common sublist of two lists"
+HOMEPAGE="http://urchin.earth.li/~ian/cabal/lcs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ dev-haskell/cabal"
diff --git a/dev-haskell/lcs/metadata.xml b/dev-haskell/lcs/metadata.xml
new file mode 100644
index 000000000000..fa121ce23df5
--- /dev/null
+++ b/dev-haskell/lcs/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Provides a function lcs that takes two lists and returns a longest
+ common sublist. For example, lcs &quot;abcd&quot; &quot;acbd&quot; is either &quot;abd&quot; or
+ &quot;acd&quot;.
+
+ The package provides a simple, stupid and (most of all) slow
+ implementation that needs, for inputs of length m and n, O(m+n)
+ space and O((m+n)!) time in the worst case.
+
+ It also provides an implementation of the Hunt-Szymanski LCS
+ algorithm, based on that in &quot;String searching algorithms&quot; by
+ Graham A Stephen, ISBN 981021829X.
+
+ Given inputs xs and ys of length m and n respectively, where there
+ are r pairs (x, y) where x is in xs, y is in ys and x == y,
+ Hunt-Szymanski needs O(r+m+n) space and O((r+m+n)*log(m+n)) time.
+ Thus this is O((m+n)^2) space and O((m+n)^2*log(m+n)) time in the
+ worst case.
+ </longdescription>
+</pkgmetadata>