summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/libmpd/libmpd-0.8.0.4-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/libmpd/libmpd-0.8.0.4-r1.ebuild')
-rw-r--r--dev-haskell/libmpd/libmpd-0.8.0.4-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/libmpd/libmpd-0.8.0.4-r1.ebuild b/dev-haskell/libmpd/libmpd-0.8.0.4-r1.ebuild
new file mode 100644
index 000000000000..f508b53d1a2c
--- /dev/null
+++ b/dev-haskell/libmpd/libmpd-0.8.0.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An MPD client library"
+HOMEPAGE="http://github.com/joachifm/libmpd-haskell#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # Could not find module Test.Hspec.Monadic
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.1:=[profile?] <dev-haskell/attoparsec-0.13:=[profile?]
+ >=dev-haskell/data-default-0.4.0:=[profile?] <dev-haskell/data-default-0.6:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/network-2.1:=[profile?] <dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/utf8-string-0.3.1:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/data-default
+ dev-haskell/hspec
+ dev-haskell/hunit
+ dev-haskell/mtl
+ dev-haskell/network
+ >=dev-haskell/quickcheck-2.1
+ dev-haskell/text
+ dev-haskell/utf8-string )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'attoparsec >= 0.10.1 && < 0.12' 'attoparsec >= 0.10.1 && < 0.13'
+}