summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-03 19:10:17 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-03 19:10:57 +0100
commitdfa1761e84c85af500013f3382f1d4f99ad6c1a8 (patch)
treef0171abc092f85abf4367f1ddb37a29980c66159 /dev-haskell/linear/linear-1.20.6.ebuild
parentapp-emulation/containerd: Version bump to 0.2.9 (diff)
downloadgentoo-dfa1761e84c85af500013f3382f1d4f99ad6c1a8.tar.gz
gentoo-dfa1761e84c85af500013f3382f1d4f99ad6c1a8.tar.bz2
gentoo-dfa1761e84c85af500013f3382f1d4f99ad6c1a8.zip
dev-haskell/linear: bump up to 1.20.6, bug #623590
Adds support for ghc-8. Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/623590 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-haskell/linear/linear-1.20.6.ebuild')
-rw-r--r--dev-haskell/linear/linear-1.20.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/linear/linear-1.20.6.ebuild b/dev-haskell/linear/linear-1.20.6.ebuild
new file mode 100644
index 000000000000..2408f5add628
--- /dev/null
+++ b/dev-haskell/linear/linear-1.20.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.2.9999
+#hackport: flags: -herbie
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Linear Algebra"
+HOMEPAGE="https://github.com/ekmett/linear/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+template-haskell"
+
+RDEPEND=">=dev-haskell/adjunctions-4:=[profile?] <dev-haskell/adjunctions-5:=[profile?]
+ >=dev-haskell/base-orphans-0.5:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/bytes-0.15:=[profile?] <dev-haskell/bytes-1:=[profile?]
+ >=dev-haskell/cereal-0.4.1.1:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
+ >=dev-haskell/distributive-0.2.2:=[profile?] <dev-haskell/distributive-1:=[profile?]
+ >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/lens-4:=[profile?] <dev-haskell/lens-5:=[profile?]
+ >=dev-haskell/reflection-1.3.2:=[profile?] <dev-haskell/reflection-3:=[profile?]
+ >=dev-haskell/semigroupoids-3:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
+ >=dev-haskell/semigroups-0.9:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.4.4:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.4:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/void-0.6:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ >=dev-haskell/cabal-doctest-1 <dev-haskell/cabal-doctest-1.1
+ test? ( >=dev-haskell/doctest-0.11.1 <dev-haskell/doctest-0.12
+ >=dev-haskell/hunit-1.2.5
+ >=dev-haskell/simple-reflect-0.3.1
+ >=dev-haskell/test-framework-0.8
+ >=dev-haskell/test-framework-hunit-0.3 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-herbie \
+ $(cabal_flag template-haskell template-haskell)
+}