summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-22 23:35:54 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-22 23:38:48 +0100
commitb3c0f576d713ce47581a1d01fd0f33b2ee65d190 (patch)
treef463da9fc1a36f2987a6b8916a900437650d4b26 /dev-haskell/microstache
parentdev-haskell/statistics: bump up to 0.15.2.0 (diff)
downloadgentoo-b3c0f576d713ce47581a1d01fd0f33b2ee65d190.tar.gz
gentoo-b3c0f576d713ce47581a1d01fd0f33b2ee65d190.tar.bz2
gentoo-b3c0f576d713ce47581a1d01fd0f33b2ee65d190.zip
dev-haskell/microstache: new package, a depend of criterion-1.5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/microstache')
-rw-r--r--dev-haskell/microstache/Manifest1
-rw-r--r--dev-haskell/microstache/metadata.xml14
-rw-r--r--dev-haskell/microstache/microstache-1.0.1.1.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/microstache/Manifest b/dev-haskell/microstache/Manifest
new file mode 100644
index 000000000000..11bf947486f0
--- /dev/null
+++ b/dev-haskell/microstache/Manifest
@@ -0,0 +1 @@
+DIST microstache-1.0.1.1.tar.gz 20449 BLAKE2B b4f0a6b13e5597ba2c90377032a8b248570977a35bb07d7f8b360add87eff6ea80ee8cbd40cee8e110ff913833b798234d0189e65e4c4964367b3643c15e6837 SHA512 28e0ad58a9724259df176092c125a4ba51fd2278cb0ab2e29bc24bf1e0f1c57a53e5983ff640569e3416fc7cda31b6ba0ae8ad832840a3040ba55fb85fb7f1a1
diff --git a/dev-haskell/microstache/metadata.xml b/dev-haskell/microstache/metadata.xml
new file mode 100644
index 000000000000..2f8ed16ae4ad
--- /dev/null
+++ b/dev-haskell/microstache/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Mustache templates for Haskell.
+
+ Based on @stache@ library, which uses @megaparsec@.
+ This library uses @parsec@, thus the name: @microstache@.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/microstache/microstache-1.0.1.1.ebuild b/dev-haskell/microstache/microstache-1.0.1.1.ebuild
new file mode 100644
index 000000000000..9286cf331bb4
--- /dev/null
+++ b/dev-haskell/microstache/microstache-1.0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Mustache templates for Haskell"
+HOMEPAGE="https://github.com/phadej/microstache"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
+ >=dev-haskell/parsec-3.1.11:=[profile?] <dev-haskell/parsec-6.0:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.11:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'aeson >=0.11 && < 1.3' 'aeson >=0.11' \
+ 'containers >=0.4.2.1 && < 0.6' 'containers >=0.4.2.1'
+}