summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-24 08:10:30 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-24 08:10:58 +0100
commitdc57a9b07e464f1c467e46f1c88a7c5badf2357b (patch)
tree88ea58ab4580b64f878398cd9fd5306673339875 /dev-haskell/monadcatchio-mtl/monadcatchio-mtl-0.3.1.0-r2.ebuild
parentapp-eselect/eselect-mpost: Remove last-rited pkg (diff)
downloadgentoo-dc57a9b07e464f1c467e46f1c88a7c5badf2357b.tar.gz
gentoo-dc57a9b07e464f1c467e46f1c88a7c5badf2357b.tar.bz2
gentoo-dc57a9b07e464f1c467e46f1c88a7c5badf2357b.zip
dev-haskell/monadcatchio-mtl: tweak for cabal-3
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/736108 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/monadcatchio-mtl/monadcatchio-mtl-0.3.1.0-r2.ebuild')
-rw-r--r--dev-haskell/monadcatchio-mtl/monadcatchio-mtl-0.3.1.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/monadcatchio-mtl/monadcatchio-mtl-0.3.1.0-r2.ebuild b/dev-haskell/monadcatchio-mtl/monadcatchio-mtl-0.3.1.0-r2.ebuild
new file mode 100644
index 000000000000..9ec899f3c7f2
--- /dev/null
+++ b/dev-haskell/monadcatchio-mtl/monadcatchio-mtl-0.3.1.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="MonadCatchIO-mtl"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Monad-transformer version of the Control.Exception module"
+HOMEPAGE="http://darcsden.com/jcpetruzza/MonadCatchIO-mtl"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/monadcatchio-transformers-0.3.1.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # default is not compatible to Cabal-3
+ rm Setup.lhs || die
+ cabal_chdeps \
+ 'MonadCatchIO-transformers==0.3.1.0' 'MonadCatchIO-transformers>=0.3.1.0'
+}